Gradle version 1.6 is required using Android Studio

Asked By 40 points N/A Posted on -
qa-featured

Hi experts,

I have a problem with Android Studio; I am getting an error message. The problem triggered only after the update, before update it used to work to the core. I tried the link in the log window to set up the grade nothing seems to work. I tried all the option in the list but no luck. How I can solve this error? Thanks.

Resolve error

Gradle version 1.6 is required. Current version is 1.8-20130730220035+0000.

Please fix the project’s Gradle settings.

Consult IDE log for more details (Help I Show Log)

OK

SHARE
Answered By 564735 points N/A #188208

Gradle version 1.6 is required using Android Studio

qa-featured

I don’t understand it. How come Android Studio will require and old version of Gradle such as version 1.6 though you already have Gradle 1.8. The latest version, by the way, is Gradle 1.11. Anyway, since Android Studio requires that version, you can download it from Gradle Automation Evolved. To download the version required, in Previous Releases section, select “1.6” and then click on the version compatible with your operating system. See image.

Once downloaded, install it and then run Android Studio again. See if this works. Also, make sure all modules are already installed like Eclipse 3.7.2 and up, Eclipse JDT plug-in which is already included in the majority of Eclipse IDE packages, JDK 6 and up, and Android Development Tools plug-in.

Remember, if you only have JRE or Java Runtime Environment, this is not enough. You need JDK to make it work. For Windows users, Android Studio requires Windows XP x86, Windows Vista x86 or x64, or Windows 7 x86 or x64. For Mac users, it supports Mac OS X 10.5.8 Leopard and up x86 only.

It also works on Linux. For the complete specifications, visit Get the Android SDK.

Login/Register to Answer

Related Questions