Google App Engine failed me this time

Asked By 30 points N/A Posted on -
qa-featured

It was just yesterday when I wanted to deploy a new application to the Google App Engine.

I have done this many times, but I was somewhat surprised that the deployment failed with the following message:

“Deploying app_id to Google has encountered a problem 401 unauthorized Must authenticate first”.

Please help me solve this.

Any help is much appreciated.

SHARE
Best Answer by Tamara Francic
Best Answer
Best Answer
Answered By 0 points N/A #144309

Google App Engine failed me this time

qa-featured

If you wish to install the application in the default servlet container beyond the GAE, you can prefer to use the com.vaadin.terminal.gwt.server.ApplicationServlet as an alternative to com.vaadin.terminal.gwt.server.GAEApplicationsServlet.

Just remember that there is an issue with the newest GAE plugin which stops this from working. If you receive an error such as, The App Engine SDK 'C: <workspace path><project name>war' on the project's build path is not valid, do the following steps to correct it:
 
  1. Launch the Preferences> Google> App Engine> Choose the SDK version
  2. Launch  the Preferences> Java Build Path> Export Order. And then modify the Export Order to put the App Engine SDK on top of the Web App Libraries classpath container.
  3. Set the GAE to Enable.
  4. Under the Project Preferences, tick the Use Google App Engine check box on Google/App Engine.
  5. Click My Applications…
  6. Log in using your Google App Engine username and password.
  7. Make a new web application under the My Applications.
  8. Insert the created application ID to your project configuration under Eclipse.
  9. Code and then set up your application.
  10. Right-click on Project option to open the App Engine list and then choose the Google/Deploy or just click the Deploy to App Engine icon under the toolbar menu.
  11. Launch the application in http://yourapplicationid.appspot.com
 
Thanks 

Login/Register to Answer

Related Questions