No of visitors who read this post: 7799
Category: Security
Type: Question
Author: Audreyreed
Your rating: None Average: 5 (20 votes)

When I am trying to open my Windows Firewall an error is appearing instantly, the error code id is 0x6D9. This error occurred after deleting webroot antivirus from my system.

I'm starting to receive an alert that my firewall has been turned off. While I was trying to turn my firewall on, this error appears. I was just about to change my anti virus that's why I deleted webroot. The other security software installed on my computer is a trial version of Norton 360 which came as a pre installed software when I bought my computer. But I still disabled it. Then reboot my system. It doesn't work.

There was an error opening the Windows Firewall with Advanced Security

The Windows Firewall with Advanced Security snap-in failed to load. Restart the Windows Firewall service on the computer that you are managing. Error code: 0x6D9

So I totally deleted Norton, then restart again, still no luck. I searched on one site and according to them, I need to check that my firewall startup is set to automatic. But they don't include any links or ways on how to do this. Does anyone here knows how to set it to automatic? Maybe this will solve the issue. My system is running Windows Vista SP1.

But if you have better suggestions on how to solve this, please let me know. I'm sure all of you knows how important our firewall is. Thank you.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 11442

Hi,

I have read your queries for the firewall issue that you have and here are the steps that you need:

  1. Disable third party firewalls or virus protections on the computer,  if you have any and then check if Windows Firewall Service is on.
  2. Click Start button at the lower left corner on the screen
  3. On the start search bar
  4. Type in: services.msc on the search bar
  5. The services screen will load up
  6. The User Account Control will ask you permission if you want to continue, click Continue or enter administrator’s password to continue (the password will be shown if you are not the administrator user of the computer)
  7. On the Services window, we need to look for the Windows Firewall at the very bottom part of the screen and then double-click it.
  8. The properties window will load up, we need to set the Startup type to Automatic
  9. Click Start to start the service at the upper left hand corner of the screen.
  10. If the windows firewall shows that it’s already running, click the Stop button
  11. Confirm it by clicking Yes to stop the service
  12. Click restart the service by clicking the Start button again at the upper left hand corner of the screen
  13. Click OK to exit from Windows firewall Properties window and close the Services window
  14. After restarting the windows firewall service, try turning on the Windows Firewall.
  15. Click the Start button at the lower left corner of the screen
  16. Click Control Panel from the list of menus
  17. Click Security
  18. Click Windows Firewall
  19. Click Turn Windows Firewall on or off (There might be a windows asking you to enter the administrator password, we need to enter it to finish the process)
  20. Click On for it to be activated
  21. Click OK

If you want the firewall to block everything, including the programs selected on the Exceptions tab, select the Block all incoming connections check box. You can also edit some settings of the window firewall just like your editing the settings of a virus protection, since windows firewall is also a virus protection just like Norton or McAfee.

The only difference is that windows firewall only has the firewall protection in it unlike other protection that has other features like anti-spam. Anti-spyware and others.

# Comment Id: 18581

Hi Audrey, foremost I would suggest that you confirm that service of Windows Firewall is initiated and if the startup type has been put on Automatic. To achieve this, do the following steps.

·         Select start, key in services,  right click the services tap from the list that appears, select “ Run as administrator”

·         If you are requested for an Administrator code word or confirmation, Key in your code name or select continue.

·         From the services listing, click twice on the Windows Firewall, modify the startup option to Automatic, Click Start and finally click ok.

When you have successfully done the above steps, check the Firewall settings.

·         Select the Control Panel tab

·         Select the security centre option; confirm if the Firewall icon is ON.

·         If Firewall icon is OFF, Then select windows Firewall in the left panel of the Window and alter the settings

I would also suggest that you run “Full Service Scan” 

# Comment Id: 26092

Wow!

Thank you for sending detailed and step by step guidelines on what to do.

I manage to resolve the problem.

Thank you both.