Device not recognized (USB 6008) in Windows XP Embedded

Asked By 480 points N/A Posted on -
qa-featured

I have successfully installed the NI USB 6008 device on quite a few XP Embedded machines. I'm not sure if XP embedded is supported or not. But it seems to have worked up until now. We now have a new batch of XP embedded machines and I can no longer get the driver to install.

I have tried using both the NI DAQmx v9.0.2 and NI DAQmx v9.2.1. I have also tried the full download (all crazy 1.2 GB of it) and the 'Core' version. All of the versions claim to install successfully but when I plug the USB-6008 into the USB port Windows says the USB device is not recognized. I found a patch for a USB problem (NI-DAQmx 921p1.zip) and applied that but it hasn't made any difference.

I also tried the NIDeviceDriverDatabaseRepairUtility.exe but that didn't work either. I tried also adding the NI DAQmx 8.7.1 Runtime 5 components into the image but the lists have many missing dependencies. Is there any other component I should add up with the runtime component listed on the site:

http://joule.ni.com/nidu/cds/view/p/id/1111/lang/en

I have uninstalled and installed many times. Once after installing V9.2.1 it complained it couldn't find niede.sys for an NI Ethernet Device Enumerator. I found the file but it didn't help when I pointed it at the file location. The installation finished but still the device was not recognized.

I always install the software before inserting the USB cable.

Does anyone have any idea what the problem may be, or ideally know how to fix it.

SHARE
Best Answer by Robert S.
Best Answer
Best Answer
Answered By 0 points N/A #101624

Device not recognized (USB 6008) in Windows XP Embedded

qa-featured

First of all, from what I can decipher? The problem is not actually a device driver problem. If Windows gives you a “Device Not Recognized” error, it means that Windows fails to communicate properly with the USB device thus prompting for that error. 

This is especially true if the error message appears on the bottom right corner of your screen in a balloon type message in the system tray. This has happened to me a couple of times.

If the image below is the exact same thing that you are seeing in your machine, then there are things to be done, but I assure you that it is not a driver issue as this error can also occur on plug and play devices and other USB devices that were already installed successfully on a system. It’s more on how the USB device is connected to the system.

  1. Check the USB cable that you are using. I assume that you are using a USB cable to connect the computers to the NI USB 6008 device. If so, are you using a new USB cable? Check the entire length of the USB cable that you are using, and make sure that there are no open parts or damaged parts. Also, you might want to check the contact points at the end of the cable. Make sure that the copper heads do not have any rust, oxidation or misalignment. All these factors cause that certain error message. Try other cables if needed.
  2. Make sure that you plug in the USB device correctly. Meaning, straight and well placed. There are times that just a slight angle on how you plug the device causes this kind of error message, and as such it is advisable to make sure that you are plugging it correctly. It is advisable to check both the NI USB 6008 device and the computer and how the USB cable is plugged to both machines.
  3. Check the USB ports on your computer. Have you tried using other USB devices on the computer? Did it work? Have you also tried using other ports on the computer? As there might be a problem with the USB ports itself. I know that these are new systems, but it’s not uncommon to have factory defects on some computers and that might be the cause of your problems right now.
  4. Lastly is to check the BIOS settings of the new computers. Depending on the BIOS version you are using, there are settings that control the USB ports on the motherboard. Check your BIOS and determine if such an option is available, if there is, try changing the setting and try using the device in question again.

When it comes to USB troubleshooting, you have very limited options to try. As such, all these 4 solutions are the only things that you will be able to try on your problem. Now depending on the results of these and if you have other information that you might be able to provide, there might be other possible solution. 

As for the moment, this is for general USB troubleshooting. And again the error message that you got does not have anything to do with the Device Driver. 

The image above was taken from my own system, and it was created by just inserting my external optical drive’s USB cable with a slight angle.

USB Device Not Recognized
Answered By 0 points N/A #101625

Device not recognized (USB 6008) in Windows XP Embedded

qa-featured

Hi Steve,

Below are my suggestions:

1. You may want to check if the PC you are trying to install to the USB has the same OS, software, hardware as the previous one. If they don't have, maybe you want to use the same specifications you have used on the previous computers that NI USB 6800 has worked.

What version of Windows XP you currently have? Is it XP 64 bit or 32-bit? As this might be another factor.

Also you may want to try NI USB 6008 on another PC as to check if it will work out, if not then maybe the device is the one with the problem.

2. Check USB drivers and USB software.

You mentioned that you are used to installing the software first before inserting the USB cable. I suggest that maybe this time you might want to do the opposite. Try plugging the USB first before installing the software as this will let the computer detect the device and automatically open the Windows Hardware Installer Wizard. On this way you can be sure that the USB has been detected properly by the computer.

Now, it will all come down to software. After you are finished with the installation of the driver software of USB 6008, the NI-DAQ software has also been installed as this comes along with the installation. For this you may want to test and configure the NI USB 6008 application. I’m pretty sure you already know what to do next.

Also I would like to add the following factors that you have to consider:

What does the version of DAQ have you installed, and is the BIOS updated? Are you using LabView or your own software?

Hope this helps,

Celine

Login/Register to Answer

Related Questions