Collision doesn’t work for me

Asked By 0 points N/A Posted on -

Hello experts,

I am using SDK 4.2 having COCOS 2D 0.99.5 and also COCOS2D 0.99.4. The difficulty is, when I try to create TMX file via Tiled Map Editor version QT-0.6. There, for the meta layer, I have enabled the collision facility, but collision doesn’t work for me. I wonder that same file readily works in the COCOS 2D 0.99.3 and also COCOS2D 0.99.2.

Answered By 20 points N/A #124393

Collision doesn’t work for me



I think its not that ugly which it seems. It may be because your trigger is stationary, but I have got stationary triggers in some other programs as well but do not causing any issue.

You should try to go to EDIT ->PROJECT SETTING->PHYSICS and set SLEEP AND SLEEP ANGULAR  VELOCITY to zero (0) now check any thing positive happen and it resolve your problem.

EDIT: Following the above will make physics update everything every frame, and even if its stationary, It’s a resource hog. Also what happens if you have the debug on the trigger? 


Login/Register to Answer

Related Questions