Annoying Problem Ejecting USB Mass Storage Device Error

Asked By 0 points N/A Posted on -
qa-featured

Greetings fellow TechyV members,

I have this problem where I often encountered "Ejecting USB Mass Storage Device Error". I have experienced this quite often when I'm using my Portable Hard Disk or any other Storage Devices. I tried to close every program that accesses my Hard Disk, I even tried to use the Task Manager using Ctrl+Alt+Delete and stop all running processes that access my Hard Disk but still it won't eject successfully. So I ran out of patience and just pulled the plug directly. I know that this method is not good but I have no other choice.

I want to ask your advice on what should I do regarding this problem. Is there any special software that I can buy in order to successfully eject my devices every time?

Please, if you do have some suggestions on how to accomplish this task, do tell me. Thank you.

More power to TechyV.

SHARE
Best Answer by cathie
Best Answer
Best Answer
Answered By 0 points N/A #84310

Annoying Problem Ejecting USB Mass Storage Device Error

qa-featured

Hey Robe Bell!

The problem is that when you transfer some files from USB to computer and clipboard is still running that file simultaneously, you cannot eject the USB, so this error shows. The simple solution is that, while ejecting the USB from PC, you must close all the windows on the clipboard so that you can eject the USB easily.

If the problem remains the same, then just be sure that the your USB is not troubled by viruses which could cause this problem. Clean up viruses from your USB.

Regards!

Answered By 0 points N/A #84312

Annoying Problem Ejecting USB Mass Storage Device Error

qa-featured

Hi Richie,

"Ejecting USB Mass Storage Device Error" occurred because the system is using the drive; if you have any programs open that is using any file in the drive, you can't safely remove it.

The simplest solution is to close every file the drive has opened. Another way, close all apps from task manager process window.

If the problem persists, you can use CTRL+ALT+DEL and bring up task manager, then run the process explorer.exe manually and attempt to remove the drive.

If none of these solutions work, then you have to reboot your computer with the drive in the port.

More power to TechyV.

Answered By 0 points N/A #84313

Annoying Problem Ejecting USB Mass Storage Device Error

qa-featured

After you've finished saving your files on your USB drive, you want to remove your drive safely but suddenly you cannot safely remove it. You may see these error words displayed on your monitor when you click safely remove hardware: “The device cannot be stopped right now”. “Try stopping the device again later”.

Here are the possible reasons with this problem:

1. There are still other programs running that are using your USB storage –Close all the programs that you used, then remove your USB safely.

2. Possible virus is infecting your USB device, causing it not to be safely removed – Clean up your USB first. 

3. You can also use CTRL+ALT+DEL (task manager), and run the explorer.exe and try to remove the drive.

4. If the problem still continues, try to shut down your computer and then safely remove your USB pen.

Take care!I hope this would help you.

Login/Register to Answer

Related Questions