Adobe Flash CS3, ActionScript 3.0 Error

Asked By 0 points N/A Posted on -
qa-featured

I am having this very unusual error while importing the frame contents to a MovieClip. I copied this MovieClip from AS 2/ Flash 8 to Flash 9 but I got the error below: 

 

Adobe Flash CS3

This feature is not supported by Flash Player 9, ActionScript 3.0. To use this feature, you must target Flash Player 9, ActionScript 3.0.

I am thinking of importing from AS 3 file if that will fix the problem. But I need your ideas. Thanks.

SHARE
Answered By 0 points N/A #199636

Adobe Flash CS3, ActionScript 3.0 Error

qa-featured

You already got the answer, importing from AS 3 will fix the problem, or if your project is not intensively computational, rather, it is more design-oriented then AC 2 is still useful for this kind of project.

Reason for the error:

ActionScript 3.0 is not compatible with 2.0, the 3.0 ActionScript executes very fast and this version is preferable (but not necessary) for someone who is familiar with object-oriented programming concepts because it is fully compliant with ECMAScript specification while the 2.0 runs slower but also based on the ECMAScript but it is not in full compliant.

Login/Register to Answer

Related Questions