Windows 7 Slow Performance: Physical Memory 87% Use

Asked By 0 points N/A Posted on -

For the past 3 or 4 hours, the performance of my HP laptop is quite slow. I'm only using Firefox & Google Chrome.

These are the two applications which I mostly use, but never faced any problem.

I've just checked in the Windows Task Manager & here I found that CPU usage is only 5% but the Physical Memory usage is 87%. This is something I've seen for the first time. It never reached that limit even if I'm using multiple heavy applications.

I think this 87% Physical Memory consumption is the problem, causing slow speed of my PC.

Please tell me, how can I fix this.

My PC is an HP 6G laptop, with 2GB, ddr3 RAM, Windows 7.

Best Answer by Ferdinar
Answered By 0 points N/A #119286

Windows 7 Slow Performance: Physical Memory 87% Use


Hi Enoyynosn,

Your problem is about your very high Physical Memory usage if I am correct. Then the best possible way in cutting it off is to remove programs, meaning not just the programs that you are using but the programs that your computer is using.

To check click the processes tab  to the left of the performance tab;  then upon looking on your processes try to END PROCESS the programs that you are not using, for example ( ymesenger.exe, winzip or other programs that you are not currently using ).  But be careful not to end process the beneficial programs.

This will decrease your memory usage. Also showing the processes of all users will help a lot. The more process you end, the lesser memory is used.

Best Answer
Best Answer
Answered By 0 points N/A #119288

Windows 7 Slow Performance: Physical Memory 87% Use


I don't know if you have too many opened applications that's why your RAM gets eaten that much or there are so much program that is loaded automatically during boot up. If you will terminate some of the programs you think that is eating up your physical RAM using Windows’ Task Manager, you will be gambling with all of the other applications that are running in the background.

If you are planning to continue be sure on your every click so you will not accidentally end the process of another program. And I think that will not solve the problem on your memory. The next time that Windows boots up, all of the programs you terminated will be back. In other words, you will be doing that forever.

Or you may do the other way ‘round. Shoot those programs in your startup configuration.

  1. Click Start, then Run.
  2. Type msconfig then hit Enter or the OK button.
  3. Click on Startup tab. Uncheck all the programs on the list that you think you don’t need. These are all the programs that load automatically every time your computer boots.
  4. Click Apply when you’re done unchecking then OK.
  5. Restart your computer.

See the difference now in your physical RAM memory after you removed those unwanted programs from loading during startup.

Answered By 589160 points N/A #306336

Windows 7 Slow Performance: Physical Memory 87% Use


If you noticed the sudden lag on your computer, that’s because you have two web browsers running simultaneously. Even if no websites are opened on the browsers, it still consumes your computer’s memory. And when the memory consumption is high, your system will surely slow down. Also, if you will check your image, under “System” section, the “Commit (MB)” registers at 2522 MB out of 3819 MB.

That’s around sixty-six percent (66%) of the 3819 MB total page file. It is your system’s page file or virtual memory and normally when it reaches past fifty percent (50%) or when the page file usage goes beyond fifty percent (50%), things start to slow down. To fix the problem, restart your computer and open one web browser only.

Modern web browsers nowadays support tabbed browsing so make use of it. You can visit different websites simultaneously even on a single browser using the tab. This reduces memory consumption instead of running two browsers simultaneously to access different websites.

Login/Register to Answer

Related Questions