Virtualbox error 0x80004005 – Windows 7

Asked By 90 points N/A Posted on -

Hi guys,

I have windows 7 OS installed on my system. My brother wanted to use windows XP on the same system. For this purpose a friend of mine suggested me to install VirtualBox. So I have recently installed it on my PC.

Using VirtualBox, I created a machine that only I could access and not my brother. The machine has windows XP Pro having MS office and a few other applications. Everything was running smoothly so I decided to make the machine that I created accessible to both of us but unfortunately I broke it.

I wanted to put the virtual machine in a place where both of us could access it. The file name is "WinXP.vdi". I wanted to do it so I could then make a new machine with VirtualBox using the same file. Whenever I try to make a new machine with the above mentioned way, the following error pops up on the screen:

NS_ERROR_FAILURE (0x80004005)

VirtualBox – Error

Failed to open the hard disk

/home/ogp/VirtualBox VMs/WINXP/WINXP.vdi.

The medium '/home/ogp/VirtualBox VMs/WINXP/WINXP.vdi' can't

be used as the requested device type.


Result Code:          NS_ERROR_FAILURE (0x80004005)

Component:           Medium

Interface:               IMedium {9edda847-1279-4b0a-9af7-9d66251ccc18}

Callee:                  IVirtualBox {d2de270c-1d4b-4c9e-843f-bbb9b47269ff}


The error reads: "The medium <filename> can't be used as the requested device type", and the result code is "NS_ERROR_FAILURE (0x80004005)". Now the situation is that both the users cannot access the machine although we both fall in the same group "vboxusers".

I have tried to resolve the issue myself but I could not succeed. I also replaced the .vdi file with its original location but the problem is still there.

I have searched this problem on the net and I found a lot of solutions too but none of the solutions worked out for me. When I rename the VirtualBox folder in the home directory, no changes are seen.

When I give the command:

sudo /etc/init.d/vboxdrv setup

It gives me the following error:

"sudo: /etc/init.d/vboxdrv: command not found"

I think that I can erase the .vdi file and again start from the beginning but I don’t want to take this step.

Now I have also installed Ubuntu on my PC thinking that it would be easy for me have the .vdi file and I will not have to make the virtual machine again from the very beginning.

I have the version 11.04 of Ubuntu and VirtualBox 4.0.4_OSE r70112 installed on my system.

I have also installed the latest version of DKMS to enable the device drivers.

Anybody else with the same kind of problem, please do let me know if you have the right solution.

Looking forward to your replies.

Regards and take care.


Answered By 0 points N/A #140059

Virtualbox error 0x80004005 – Windows 7


Virtuals box error is one of the boring error. i think i know your problem you went to try this way, Are you running the OSE (Opensource edition) Or the non-free edition? It's just that the OSE edition is the one that comes with the repos in Ubuntu and that does not support USB virtualization. Have you tried uninstalling the extension pack first then the program itself?

Login/Register to Answer

Related Questions