Unable to format the 8900 using Blackberry Swiss Army Knife

Asked By 20 points N/A Posted on -


I've done a little research to try and fix this problem, but there doesn't seem to be one consistent answer.

Also, I am sorry if this has already been dealt with in other threads, I am at my wits end here!

I had a friend who had 8900, which I bought, but I saw it was running on 4.0 software and was really cluttered and slow. I found a video that demonstrated how to format the device with a program named Blackberry Swiss Army Knife. I backed up all my files and proceeded to do it. Also, I have installed three separate operating systems. Before I did this, I tried to update the phone software using Blackberry desktop, but it kept on freezing. I then updated the software, and I think it solved the problem (can never be too sure though!). 

Anyway, I have looked at different videos, and they recommend using app loader, even though apparently, an app loader and the install have nothing to do with one another. When I attempt to install the OS using BBSAK (device connected), I get the following error Popup;

Device Apllication Selection

Application Loader Wizard

Device Application Selection
Choose the applications that are to install or removed from your device.
The blackberry Desktop Software does not have
BlackBerry Software for the device that you have connected to the computer. Contact your wireless service provider or system administrator.
                                                          Total Application Space:0 k
                                     Back         Next        Cancel

When I try and connect with the Desktop software, I get the following;

cannot comminicate with conected device


BlackBerry Desktop Software
BlackBerry Desktop Software cannot communicate with the connected device.
If the device is rebooting or dead battery. Clink Retry to attempt to reconnect once the device reboots.
If the click Retry doesn't connect the device isn't rebooting with a changed battery. You might need to update your BlackBerry Device Software to connect the
Trouble Shoot your device connection
                                                                  Retry    Update.    Close

It has been suggested that I remove Common files RIM, which I did. Also, I took the software out and reinstalled it. I hope, this makes sense, and someone of you experts would be able to help me.

I like this phone and really don't want to use it as a paper weight.

Thanks in advance.

Answered By 10 points N/A #151709

Unable to format the 8900 using Blackberry Swiss Army Knife


Hello Mega,

The possible cause of that problem is the network connection protocols are not enabled at the time you are installing the Blackberry Playbook driver. The following are the resolutions you should try:

  • Make sure that the following settings have been turned ON in the Research in Motion Network Driver under Network Connections:

    • The Microsoft Networks Client
    • Printer and File Sharing service for Microsoft Networks
    • Internet Protocol.

The procedure for enabling the settings may be a little different depending on which operating system you are using. Once the settings are on, try running the installation again and see if it works.




Related Questions