Unable to display content error message

Asked By 20 points N/A Posted on -

I am getting this error message on my Windows XP Professional SP 3 machine. Not sure what it means.

I am trying to log into my Logitech Harmony 670 , I give in my credentials and then login. When I click on Next there is an error message which pops up:

Unable to display content. Click Next to continue



I am using Harmony 670 and once I click on next it comes back again to the login screen again. I have the latest download package installed. I have tried it on other MAC machine also and it comes up with the same error message.

Best Answer by David_02
Best Answer
Best Answer
Answered By 0 points N/A #85461

Unable to display content error message


An account configuration issue is causing this error. To solve this, you have to run the Activity Wizard, one at a time, for all Activities. Open the Harmony Remote Software and login, then select the first activity and click settings. Then click the radio button for 'Review the settings for this Activity'.

Then select 'No, I want to run the set up wizard again to change these settings'. Click next, then make sure you answer all the questions correctly. Usually a setting will be unselected, causing the error. Repeat for every activity, and attempt to update each time to check if the error has been corrected. Good luck!

Answered By 5 points N/A #85464

Unable to display content error message


Hello Kenneth,

What you are getting could be issues with session timing, and therefore you will need to quit the session harmony application and then reopen it again and see if that will resolve the issue.

Otherwise the issue could be as a result of the following reasons:

  • The setup application that you used to install the application could have had a bug that is causing the error that you are getting right now. You will therefore need to get another setup and use it for installation.
  • There could have been a problem with the installation process you used, and therefore you will need to try a reinstallation and see if it will resolve the issue.



Login/Register to Answer

Related Questions