Steps To Solve ‘windows7 Aero Theme Not Working’ Problem

Asked By 0 points N/A Posted on -
qa-featured

Hi! I use Windows 7 in my system. But, in my Windows 7, an aero theme not working. How can I solve this problem?

SHARE
Answered By 0 points N/A #323536

Steps To Solve ‘windows7 Aero Theme Not Working’ Problem

qa-featured

Firstly, you have to check whether your Version of windows7 supports the aero theme or not. Further, you can follow these steps-

  • Aero theme is supported on Windows7 Ultimate, Home Premium, and Business Edition.
  • Make sure that your graphic card supports WDDM.
  • Now, right-click on the desktop.
  • Click on ‘Personalize.’
  • Select ‘Themes.’
  • Now, select ‘Default Windows Theme.’
  • Select ‘Enable Transparency.’
  • Type ‘services.msc’ in the Run dialog box.
  • Click on ‘Run.’
  • Set ‘Desktop Windows Manager’ on ‘Automatic.’
  • Copy and paste these commands in the CMD window.

rundll32.exe

Dwmapi.dll

DwmEnableComposition

  • Now, press ‘Enter.’
Answered By 590495 points N/A #327520

Steps To Solve ‘windows7 Aero Theme Not Working’ Problem

qa-featured

If the Aero theme is not working on your Windows 7, here’s how to fix it. First, check and verify that your Windows edition supports Aero and your video card supports WDDM driver. Aero is supported on the following editions:

  • Home Premium
  • Ultimate
  • Business

To check your video card for WDDM support, press the Windows key + R to bring up the “Run” dialog then type the following and then hit Enter:

dxdiag

In “DirectX Diagnostic Tool” window, go to “Display” tab then on the right under “Drivers” section, “Driver Model” should display the WDDM version.

Checking the WDDM version
Checking the WDDM version

Right-click an empty spot on your desktop then select “Personalize”. Click “Themes” then select the default Windows theme. Click “Window Color” at the bottom then on the next page, make sure “Enable transparency” is checked. After this, press the Windows key + R to bring up the “Run” dialog then type the following and then hit Enter:

services.msc

In “Services” window, locate the “Desktop Window Manager Session Manager” service and double-click it. Make sure “Startup type” is set to “Automatic” then click “OK”. Restart the computer then see if Aero is working. If the problem continues, press the Windows key + R to bring up the “Run” dialog then type without quotes “cmd” then hit Enter. In the command prompt window, type the following then hit Enter:

rundll32.exe Dwmapi.dll,DwmEnableComposition

This command should re-enable Aero by flushing it.

Login/Register to Answer

Related Questions