Problems connecting android phone with Kies Software

Asked By 0 points N/A Posted on -

I’m trying to connect android software to my phone but I continue to get an error message that I can’t resolve. It appears that my device can't connect with the actual kies software. However, the software claims that my device is supported. My Computer is running windows 7 and 32 bit Ultimate.


Cannot start service on the device. Please disconnect then reconnect the device.
Best Answer by Allen Kenneth
Answered By 0 points N/A #195248

Problems connecting android phone with Kies Software


Maybe I can help you. I do not know which phone you are using. Therefore, I gave you a common solution that works most of the time. Most of the time Galaxy tab face this problem. Follow these steps. If your problem is not solved after complete these steps then question again mentioning your phone model. Process is given below. Try it. I hope your problem will be solved.

  • First go to your settings.
  • Then go to "applications".
  • Then "development".
  • Then uncheck "USB debugging" plug in again.
  • Then uncheck.

I hope your problem is solved. If not then question, mentioning your phone set model.

Best Answer
Best Answer
Answered By 20 points N/A #98788

Problems connecting android phone with Kies Software


Hello Ricasulivon,


Here is a solution, this may be not the end for all every issue regarding 'Kies' But worth trying as it was of some success after all.  
  1. Open the ‘Command Prompt’ console of your computer.
  2. Type ‘cd c:windowssystem32′ in the cmd prompt window (C: is usually your main drive, if else, use the exact letter)
  3. Type and enter ‘dir msxml*’ in the cmd prompt.
  4.  If there isn't any ‘msxml6.dll’ file shown in the list which will be displayed thereafter, download the file from this link. [].
    And make certain to leave the command prompt open all the time, you need it later in the process.  

    Download the first file in the list 'were you looking for' (at the bottom of the page) File is msxml6.msi.

  5. Open the .msi file by double clicking it.
  6. Go to your command prompt again & register the libraries as described below.
    Type ‘regsvr32 msxml3.dll’ and press enter.
    Then type ‘regsvr32 msxml6.dll’, press enter again.
    You should see a message window confirming that the registry is succeeded [DIIRegisterServer in msxml6.dll succeeded]
  7. Run Kies and make sure it is working now.

Hope this would fix it. 

Related Questions