Problems with the catalyst control center

Asked By 10 points N/A Posted on -

Hello everyone,

I think I have tried just about EVERYTHING I can think of to get my drivers to run.

I’ve uses Net Framework 3.0 and 3.5 and probably service packs. Reinstalling and re-downloading also doesn’t seem to do me much good. Also tried installing it while then DCP is in safe mode but I still get the same error:  

Catalyst Control Centre: Host application

Catalyst Control Centre: Host application has encountered a problem and needs to close. We are sorry for the inconvenience.

If you are in the middle of something. The information you were working might be lost.

Please tell Microsoft about this problem.

We have created an error report that you can send to help us improve Catalyst Control Centre: Host application. We will treat this report as confidential and anonymous. 


Catalyst Control Centre: Host application

Guys I need help seriously!

Any ideas?

Best Answer by Roniel
Best Answer
Best Answer
Answered By 0 points N/A #123436

Problems with the catalyst control center

qa-featured Windows update

Hi Yvette,

I have an idea, I hope this could help you in solving your problem. Follow my instructions:

  1. Uninstall the drivers of your video card.
  2. Reboot your computer.
  3. Use the windows update to update the drivers of your computer.
  4. Open the "Start menu" and Left click the "Windows Update".
  5. Check for updates of your computer.
  6. Let your windows update download and install the updates that suitable for your computer.
  7. Wait until the Windows Update is done in "Installing and Downloading" the software that your needed.
  8. If the "Windows Update" is done. If your computer recommended you to reboot? Then reboot your computer.
  9. Wait until rebooting your computer is done.
  10. Install the DirectX the your computer needed.

That's all.

Good luck.

Answered By 0 points N/A #123437

Problems with the catalyst control center


Hello Yvette,

If you are using the same setup you used before to install the Catalyst Control Centre then it implies that is the setup that has got a problem. Therefore, you will need to download another setup, this time round make sure that you download from the manufacturer's site, and then install it.



Login/Register to Answer

Related Questions