The option to increase my computer’s lock-time is grayed-out

Asked By 0 points N/A Posted on -

I am facing an issue in which the option to increase the wait-time for my computer getting locked is unavailable or grayed out as shown in the screenshot. One of my friend said that it might be due to a Virus in my computer. I’m on Windows 7 Enterprise OS.

Can someone suggest any patch or fix for this problem.


Thanks in advance !

Best Answer by Arseno Marcos
Answered By 0 points N/A #158057

The option to increase my computer’s lock-time is grayed-out


No this is not due to any anti-virus software and is due to the group policies. You can follow the following steps to enable it, but to do it you must login to the machine using a user that has “administrator” rights.

First option is to download the “Enable Screen Savers.reg

The browser will ask you to save the file. Press “Save” and save it to your “Desktop”. Next you have to right click on the downloaded file and click on “Merge”. Next click on “Run, and “Yes” (for Windows 7) or “Continue” (for Vista, “Yes” again and “OK” when prompted.

Now open the “Screen Saver Settings” window to apply. If its already open close and re-open.

Best Answer
Best Answer
Answered By 0 points N/A #158058

The option to increase my computer’s lock-time is grayed-out


Hi Carlos,

The problem faced by you might not be necessarily due to a virus intrusion. Sometimes the windows registry values get corrupted due to some contradicting software installed in your computer.

So please try these steps to manually configure the PC locking time in the registry editor.

A)   Click on Start menu –> Open the Run prompt, type Regedit, click on OK

In Registry Editor, navigate to the location below. (see screenshot below)


Then click on Control Panel

Click on Desktop

Double click on  ScreenSaveTimeOut.

Type in how many seconds (60 seconds = 1 minute) you want for how much user idle time must elapse before the screen saver is launched, then click on OK. (see screenshot below)

Click on OK. Now you can have a check on the screen saver option regarding the wait time it will change as per the given time in the edit settings

900   = 15 mins

1800 = 30 mins.

3600 = 1 hrs

And so on  u can change the wait time as much as u want.


Answered By 590495 points N/A #310330

The option to increase my computer’s lock-time is grayed-out


That doesn’t suppose to happen when you select “Blank” in the screensaver. The options underneath it shouldn’t be grayed out. The only time the options are grayed out is when you select “(None)” in the screensaver because this disables the screensaver itself. If you suspect your computer is infected, try scanning your computer. Update your antivirus and perform a full system scan.

Another way is to download Sophos Virus Removal Tool and install it. Once this is installed, start Sophos then wait until its virus signature database gets updated. When updating is complete, click to scan your computer. Scanning will take an hour or longer depending on the size of the drive and the amount of data.

The tool scans everything on your computer including external devices like USB flash drive and external hard drive. You don’t need to uninstall your existing antivirus to use the tool. Sophos works alongside any antivirus program you may have. When a virus is found at the end of the scan, remove it then repeat the scan over and over until it no longer detects a virus.

Once the computer is clean, check the screensaver options again if it’s back to normal. If this doesn’t fix the problem, try using the system file checker utility. Click “Start”, “All Programs”, “Accessories” then right-click “Command Prompt” and select “Run as administrator” to launch an elevated command prompt. In the command prompt window, type without quotes “sfc /scannow” then hit Enter.

When you are prompted to insert the setup CD, insert your Windows setup CD or DVD on your optical drive then continue. The utility scans your computer’s protected system files for incorrect versions and replaces them with correct ones. When it is finished, close the command prompt and restart the computer. See if this works.

Login/Register to Answer

Related Questions