[iPad2]: Airplay not working on device

Asked By 0 points N/A Posted on -

Hi all,

I have an issue with Airplay on my iPad 2. When I click on “Airplay” on my device, nothing changes. It plays only Air Video. I tried rebooting, unloading and reinstalling Air Video, but to no avail.

Airplay is working perfectly on my iPad 1, iPod Touch 4g, and iPhone from Air Video.

What could have caused this? I would really appreciate if someone shed light on this problem.

Thanks ahead.

Best Answer by Burton Studebaker
Answered By 5 points N/A #94950

[iPad2]: Airplay not working on device


The problem may be on an ATV or on the IOS. Try to reset your iPad device. Hold down the home button on your iPad device and also the lock button. Do it until iPad screen turns into black. After that try resetting wireless box. Find out the switch to do so. It should be somewhere on the box. Hope your problem will be solved.

Allow AirTwist on current WiFi network
Best Answer
Best Answer
Answered By 0 points N/A #94951

[iPad2]: Airplay not working on device

Hi Felixthecat,
There are possible reasons why the AirPlay is not working on your iPad 2. Well, since you mentioned that everything works fine on your iPad 1, iPhone and iPod touch, the problem might have something to do with the iPad 2 settings.
The best suggestion that I can give is to check the setting of your iPad 2 especially the mirroring. You need to check if the AirPlay mirror of you iPad 2 is turned on. Here's how you can turn the AirPlay mirror on the iPad 2.
1. First make sure that you have IOS 5 installed on the iPad 2.
2. Check if your Apple TV is up-to-date. Check it in SETTINGS > GENERAL > UPDATE SOFTWARE.
3. Make sure to have your TV turned showing Apple TV as active.
4. Bring up the Multitasking bar on the iPad screen by pressing the home button twice.
5. Swipe to the left of the screen to see the CONTROLS.
6. Tap the AirPlay button to switch from the iPad to the Apple TV.
AirPlay button to switch from the iPad to the Apple TV
7. Now you can see the Mirroring, you just need to tap on it to turn it ON. You need to do the same if you would like to switch it OFF.
That's it! I hope this solves your issue.


Login/Register to Answer

Related Questions