Hanging of Desktop Utilities on the DZ77GA-70K desktop board

Asked By 80 points N/A Posted on -

Desktop Utilities has started to hang on my DZ77GA-70K desktop board.

I uninstalled the software, restarted my computer and then tried to reinstall the software, but I get the following error:

Intel Desktop Utilities can only be installed on a computer based on an Intel motherboard.  Install will now abort.

Do you know how I can solve this? 

Thanks in advance!

Answered By 5 points N/A #155369

Hanging of Desktop Utilities on the DZ77GA-70K desktop board


      You don’t have problem with your board since DZ77GA-70K is intel board. Have you tried to run as administrator when you try to install the software?, if not? Try to do that. Uninstall also the Intel SMBus. But if the error still there, try to check your bios if you are running or EUFI boot enabled. If you installed your windows using that option you cannot disabled that, and that EUFI boot is the cause of the problem why you encounter that error.  To disable EUFI boot on your board, you need to reset bios to default values, Hope it helps.

Login/Register to Answer

Related Questions