Google Chrome Cannot be Run as Root

Asked By 10 points N/A Posted on -

Hi TechyV!

I need some expert help. I don't want to go any further than running Google Chrome as root. This was a last desperate attempt to get the browser working. I'm afraid I might do something wrong if I force Chrome to run.

The problem is with the Google Chrome. I tried to run it as a root and received an error message. I tried to solve the problem several times but no result. Have a look at the error message below.
Have you any idea for the error message?
Please help me to solve it.
Any advice about this?
Thanks guys!

Google Chrome can not be run as root.

Please start Google Chrome as a normal user. To run as root, you must specify an alternate –user-data-dir for storage of profile information.

Best Answer by lee hung
Best Answer
Best Answer
Answered By 10 points N/A #95302

Google Chrome Cannot be Run as Root


Hi Patricia,

Though it is not advisable to run your chrome or even other programs in the super-user mode because this poses a risk of altering the files in the kernel, I will refer you to the following site for a more detailed procedure for executing chrome in root mode.

Download Link

Instead of running you linux program, I will advise that you create and administrator account with the super user privileges and maximum control over the applications, but only access the kernel when you need to make some changes that are necessary for the operation of the system. This will help guard against accidental modification of the kernel files.

Hope this helps.



Lee Hung.

Answered By 0 points N/A #95303

Google Chrome Cannot be Run as Root



Dear user,

First of all, you shouldn't run a browser as a root. If you still wish to run chrome as a root, then here are the instructions:

1) Open the Konsole Terminal.

2) In the terminal, type cd/opt/google/chrome/hexedit chrome.

3) Now press tab and switch to ASCII.

4) Now press Ctrl+ S and search geteuid. Now save it.

Hope this will help you.

Thank you.

Answered By 0 points N/A #197310

Google Chrome Cannot be Run as Root


Hey Mr,

I have come out with a simple solution to help you on this.

You can easily be able to run Chrome as root. Follow the following steps:

1. Create the following shell script:

exec "/opt/google/chrome/google-chrome" "–user-data-dir=/home/google-chrome-data-dir" $1

(Note: You will; need to create the directory you specify under -user-data-dir)

2. You will need to mark this file as executable with the following command:

chmod a+x path_of_your_shell_script_here

3. When you try to open links on your thunderbird next time,  just select this shell script as the program to do so.

4. You are done and you will find Chrome opening up links for ya!

Login/Register to Answer

Related Questions