FTP Publishing Error on Mac

Asked By 10 points N/A Posted on -

I am a new user of Mac and RapidWeaver. I have to stop working with my Windows/Flash Based websites and rewrite them due to inaccessibility to iPhone and iPad. I have already been through the checklist, I deleted the cache, and I am still stuck with the attached error below stating that

FTP Publishing Error. I have done everything that I could possibly do, but I still get the same message. I am not so familiar with RapidWeaver and Stacks. And as much as I would like to be more knowledgeable about it, I could not continue unless this error is not yet resolve.

Can someone please send me some help?

FTP Publishing Error

Failed to create remote directory 'files/


Best Answer by Allen Kenneth
Answered By 0 points N/A #109673

FTP Publishing Error on Mac



The problem may occur due to any folder of yours which hold bad authorization in FTP server. You should delete the FTP entry at the Keychain Access. Then attempt with any of your Bookmarks to Publishing Settings for testing the error was solved or still showing problematic.

Try this forum for more-


Best Answer
Best Answer
Answered By 0 points N/A #109674

FTP Publishing Error on Mac


Hello Hunter,

This is one of the most common and popular publishing problems.  

That is because of a incorrect entry in the ‘Publish Settings’ dialog on FTP details for your site

If you get this error, make absolutely certain to check you’ve typed all the information (username, password etc.) which your hosting company has provided to you with into the dialog correctly.

Most of the times this will straight away fix it. If it doesn’t, then it’s more likely that, information in your “Keychain Access” application is corrupted.

You have to use "Spotlight" in order to find the “Keychain Access”.  Press return to launch it and then search for the keychain info pertaining to your site in the ‘Login’ list. Find it and delete.  

Then you have to re-enter it in RapidWeaver. Type it manually, do not copy and paste, and you should be done. RapidWeaver will create a new Keychain entry for it in the Keychain Access.

Hope this will fix it.

Login/Register to Answer

Related Questions