Failure of ADFS 2.0 configuration wizard

Asked By 10 points N/A Posted on -

Hello everyone,

I installed the ADFS 2.0 on my PC the other day with office 365.

Now I am facing a strange situation. I attempted to run the ADFS 2.0 Federation Server Configuration Wizard, but it ended up as a failure.

The following dialog box appeared on the screen:

AD FS 2.0 Federation Server Configuration Wizard

You do not have sufficient privileges to create a container in

Active Directory at location


rosoft,CN=Program Data,DC=…………,DC=com for use with

sharing certificates. Verify that you are logged on as a Domain

Admin or have sufficient privileges to create this container, and try



I have tried my level best to solve this problem but I could not succeed. I posted this problem on many forums but still no response.

If anybody has a solution to this problem, please contact me. It'll be so nice of you.


Answered By 10 points N/A #159372

Failure of ADFS 2.0 configuration wizard


Hello Amber,

The reason why you are getting that error could be because the container might have been moved or rather deleted, or it could be completely removed. You will therefore need to do a custom search for the containers that have got a description that starts with the string "default".

After you find that string, you will need to move it to the root of the Domain tree. After that you can start the ADFS configuration wizard. ADFS should work correctly after that as well as office 365. It shouldn't fail again after that.

Hope this helps.




Login/Register to Answer

Related Questions