Error When Trying to Save MS Word Document Using Mac

Asked By 20 points N/A Posted on -

I just installed MS Office 2010, installation seems successful but the first time I tried to save a MS Word document, it quits and then I received this error: Compile error: Method or data member not found. At the same time, a code appears with a lot of technical information that I do not understand.

When I clicked OK, a new window appeared, I closed the window and then I got another message: Microsoft Visual Basic: This command will stop the debugger, after that Word closes, however, my document is saved.

What could I do to prevent this compile error and debugger from appearing every time I tried to save a document?

Answered By 5 points N/A #107492

Error When Trying to Save MS Word Document Using Mac



Save the File Locally
If you receive a file permission error when trying to save a file to a spot on your home or office network, there could be a problem with the network resource. For instance, a hard drive on the file server may have failed, or the server may be down for maintenance.
Network resources can be unavailable for any number of reasons, and it is important for workers who receive file permission errors to notify the IT department so that the network resources can be brought back online.
In the meantime, users can ensure that their files are not lost by saving a copy of the file locally. To save the file, navigate to your hard drive and choose a folder you have access to.
From there, you can simply save your work and then resave it to the network after the data connectivity problem has been resolved. Just make sure you take note of where you saved the file so you can go back to it later.
Test Your Drive Mappings
Incorrect or outdated drive mappings are a frequent source of file permission errors. If you receive a file permission error when saving to one of your drive letters, try saving to another drive letter. If one drive letter works but the other does not, there could be a problem with the drive mapping.
To re-create a drive mapping, open up Windows Explorer and look for the letter of the problem drive. Take note of which server and folder it is mapped to, that is, \myservermyshare. Then, click the "Tools" menu and choose Map Drive from the drop-down menu.
When the dialog box comes up, type the server name and folder, that is, \myservermyshare and see if it connects. If the mapping is successful, you should then be able to save your file to that drive letter. If not, there could be a problem with the network resource, and you will need to contact your IT department.
Use the Full Network Path Name Instead of the Drive Letter
If file permission errors are encountered when trying to save your work to the network, you may be able to save your work by typing the full UNC path name in the location box. For instance, if your P drive is mapped to \myservermyshare, you can simply type \myservermyshare into the location box.
If the file saves correctly, there is most likely a problem with your drive mapping, and you will need to remap that drive. If you still receive a file permission error, the culprit is probably a down or unavailable network resource, and you should notify your IT department immediately. In the meantime, you can save your work to your hard drive or to a USB thumb drive.

Login/Register to Answer

Related Questions