Error when connecting WAN Miniport (PPPOE).

Asked By 10 points N/A Posted on -


When I was attempting to join an acquaintance’s new PC on my WIFI modem we experienced several unusual warning prompts. The prompt shows connecting WAN Mini port (PPPOE). The snapshot of the error is shown below:

How can we resolve this kind of error? I'm not familiar with this stuff. Please help.


Connecting through WAN Miniport (PPPOE)-bbbsnl- Error 651
Error connecting to bbbsnl
Connecting through WAN Miniport (PPPOE)…
Error 651: The modem (or other connecting device) has reported an
If you continue to receive error messages, you can enable logging for
For logging options, see diagnostics
Logging options can also be accessed by clicking the Remote Access
Preferences menu item under the Advanced menu of the Network
Connection Folder.


Answered By 0 points N/A #144449

Error when connecting WAN Miniport (PPPOE).


I will assist you solving this problem with several options available. Choose any or you may try each of them until you find the one which works for you.

Please perform the following instructions.

A. Disabling dial a connection.

i. Go to Start and click Control Panel. Select internet Options.

ii. On Connection tab, please check the box for “Never dial a connection”.

iii. Afterwards, click Apply followed by clicking OK.


B. Performing a clean boot.

i. Firstly, your firewall is required to be turned off in order to proceed this test.

ii. Afterwards, please run a Clean Boot.

iii. Erase the existing PPP0E connection and please establish new one in Windows 7.

iv. Go to C:WindowsSystem32 folder and place the raspppoe.sys file.

v. Change the name into raspppoe.old.

vi. Get the newest one by downloading it here.


C. Disabling the IPv6 for your connection.

i. Right-click your connection , and then select Properties.

ii. Ensure that the IPv6 is disabled. Else, please uncheck the IPV6 box.

I hope this little help works for you.

Login/Register to Answer

Related Questions