An error occurred with ISDone.dll while unpacking

Asked By 20 points N/A Posted on -

Hi there,

While extracting an archive this error with not enough memory appeared. I have checked my HDD partition and I have enough available space and still. I tried many times to extract and every time the same error appeared. Can anyone provide me a solution for this error ? What memory is not enough to extract this archive ?

Thanks !

Extracting archive Data1.bin…(10.5%)


An error occurred while unpacking: Not enough memory!

Unarc.dll returned an error code:-5

ERROR: archive data corrupted (decompression fails)


Answered By 0 points N/A #175781

An error occurred with ISDone.dll while unpacking


There are 2 things that I read about your post. Here are my assessments:


1. Memory problem

2. Package problem


Let's discuss this one by one:

Memory Problem – the problem is that you don't have enough memory (HDD) that can store your files, if you've partitioned your disk into 2 (1 for operating system and another for your files), please check the installation location of your program, you might be putting the program to a smaller partitioned disk

Package problem – this occurs when the download has been interrupted and/or the package is truly corrupted in the first place, meaning, the link that you've downloaded the file is corrupted in the first place, please also consider this fact

Answered By 590495 points N/A #175782

An error occurred with ISDone.dll while unpacking


It seems like you are installing the game Civilization 5. Mine here is 2 versions older, Civilization 3 and I like playing it. After looking at your screenshot and checking on the specifications of the game, it seems you really have a problem. You see, Civilization 5 will not run on Windows 8 and your screenshot shows you are installing it on Windows 8 or maybe Windows 8.1 even.

The game Civilization 5 only supports and will work only on Windows XP Service Pack 3, Windows Vista Service Pack 2, and Windows 7. Microsoft Windows 8 is not supported. And also, the error in the screenshot that says “Not enough memory” doesn’t point to your hard disk drive free space or hard drive space.

The “Not enough memory” error points to your computer’s physical RAM or memory which means you have a very little amount of RAM left that is not enough to complete the operation. Your hard drive is not a memory. It is a storage device. You use it to store different files like when installing a game.

Though the hard drive can be used or is also used as a memory, specifically the page file, it is really meant to store data and not as a memory. To fix it, install a much higher version of Civilization that supports Windows 8 or replace your operating system with Windows 7.

Login/Register to Answer

Related Questions