Error in H 264 format

Asked By 30 points N/A Posted on -

Hi all

I have recently downloaded the Expression Encoder 4  (EE4) with SP2. When I try to load an ismv file I am met with an error on my screen. The error says:

Cannot import a zero-length file.

   at Microsoft.Expression.Encoder.MediaImportInfo.ValidateMediaFileInfo(MediaFileInfo fileInfo)
   at Microsoft.Expression.Encoder.MediaImportInfo.OpenAndValidateMediaFile(String strFilename, MediaLoadOptions loadOptions)
   at Microsoft.Expression.Encoder.MediaItem.Analyze(AudioVideoFile audioVideoFile)
   at Microsoft.Expression.Encoder.MediaItem.Analyze()
   at Microsoft.Expression.Encoder.MediaItem..ctor(String fileName)

I have encoded the smooth stream with H.264 codec and it has an individual audio file. I was met with the same error when I tried to import ismv file to EE4 and also when I was creating

Microsoft. Expression. Encoder. Media Item instance using .net.

My Silverlight player and the media player classic is functioning properly so there is no evidence of my smooth stream being corrupted. When I use windows media player a black screen appears in front of me.

I tested this with Gspot and the screenshots are attached below:

I also tested with big buck bunny H.264 sample and everything worked perfectly.

The screenshot is attached below:

Has anyone else encountered this problem and successfully fixed it up?

Please help me out to get rid of the situation. I'll be really thankful.

Looking forward to your suggestions



Answered By 10 points N/A #138492

Error in H 264 format


Hello Randy,

I highly suspect that the cause of the error has to do with the following:

  • The codecs being used. The codecs that are being used may not be able to support that file. You will therefore need to update the codecs or try changing the default codecs to other available codecs and see if that will solve the problem.
  • The audio file may not be in a format that is not supported by the Expression Encoder, and therefore you should try changing the file format and see if that will solve the issue.
  • If the above workarounds do not help, you can just try reinstalling the GSpot v2.7 application and see if that will help. It may be having some bugs that are causing the problem.

Hope this helps.



Login/Register to Answer

Related Questions