CLR Error 80004005 whenever I try to launch the game Terraria

Asked By 0 points N/A Posted on -


I recently encountered this frustrating error. Whenever I try to launch the game Terraria, I get the CLR Error shown below. I tried reinstalling the game, but it did not improve the situation. Someone suggested that this is a problem with my .NET framework and I tried uninstalling and reinstalling the .NET Framework. But this idea too did not work out for me. I even tried using a .NET cleanup utility and then reinstalled my .NET Framework. All this was useless. I have exhausted all my possibilities. Can anyone help me with this please? Your help will be greatly appreciated.

CLR error: 80004005

The program will now terminate.

Answered By 110 points N/A #179624

CLR Error 80004005 whenever I try to launch the game Terraria



This is an issue due to improper function of .NET Framework. To fix this,

1. Right-click on the program you’re having trouble to open. Select Properties >> “Compatibility” tab. Uncheck all compatibility options.

2. Go to Start menu >> Control Panel >> Uninstall a program. Find out all .NET Framework versions and select “Uninstall”.

Uninstall all .NET Frameworks and restart your PC.

3. Download the latest .NET Framework from here. Then install it.

Now try the program to run. This time, I’m sure that you’ll have no more issue.

Login/Register to Answer

Related Questions