Error failing to complete installation

Asked By 220 points N/A Posted on -

Hello,my acer lappi came preinstalled with EGis software.

Whenever i right clicked an item on the toolbar and went to task it redirected me to system32. after a bit of research i found it had something to do with MYwinLocker.

When i tried to uninstall i got a installer shied error saying "1628:failed to complete installation"

Best Answer by oliver wood
Best Answer
Best Answer
Answered By 0 points N/A #127960

Error failing to complete installation


To solve this error, please follow these steps

  1. Find Task Manager (press Ctrl-Shift-Esc simultaneously).
  2. Choose tab Process and find out any processes named Uninst16.exe, Uninst.exe, IsUninst.exe, isetup.exe or setup.exe.
  3. Choose the process name and End Process button if an installation is processing.
  4. All of temporary files shall be deleted.
  5. If the error still appears, restart your computer and uninstall the program.

Restart always is a alternative solution to fix any odd errors.

Answered By 5 points N/A #127961

Error failing to complete installation


To solve your problem you can go to these steps:

  • Go to START and then to CONTROL Panel
  • Go to performance and maintenance
  • Now select Administrative tools
  • Now select the Local security policy
  • Now check software restriction policy
  • And see there is some software restriction on your software and try  to resolve it.
  • If there is no such policy then go to action tab and set a policy such that select all users but don't select administrator and i hope your problem will be solved  as i have shown here.



Login/Register to Answer

Related Questions