Error 46 that ‘Operation to a read-only file denied’

Asked By 30 points N/A Posted on -

Hello experts,

I am getting the following error message continuously:

"Btrieve Error 46 Operation to a read-only file denied" and sometimes, error like 'some key file missing.'

I also tried to reinstall it in some other drives but, same things happen. Then I attempted command prompt as well as in data directory, I typed a command "attrib -r -s -h", but no result. Same problem persists.

Also, I tried to open it in safe mode, un-checking the read-only. I need to solve this problem. Please help me.

Thanks in advance.

Best Answer by Donald Gare
Best Answer
Best Answer
Answered By 0 points N/A #154552

Error 46 that ‘Operation to a read-only file denied’



Hi Corey Finnerty,
"Btrieve Error 46 Operation to a read-only file denied"
This means that the file your program is trying to write to/save/modify is opened currently in read-only mode. Files opened as read-only cannot be modified or written to.
A. You may not know it but sometimes the programs you are using might modify files you may not have explicitly opened yourself. 
  • If you are fully authorized to use that program, ask others who are working on the same program as you if they also have this error. You can ask your Administrator to give you the necessary write privileges to the file. 
  • In case of Btrieve, different Btrieve versions have some:

1. Incompatible Formats – files previously open for reading and writing may now only be used for reading;

2. Deprecated Features – old features are no longer supported in new versions;

3. Incompatible Requests – functions and protocols to access certain parts of data have changed for greater security to the file you are working on;
4. You might have uncovered a bug/error in your program that uses Btrieve. You can report this to Btrieve or you download Btrieve updates to obtain bug fixes.
B. Your network, other users, operating system, anti-virus or other programs might have locked the file as read-only.
1. Try to close all your programs then re-start your computer. Run only one program that you need to access that file and see if the error is replicated.
2. You might have opened another copy of the program and aborted it due to an error. The aborted program might have run some subprograms that still have write access to the file (and renders your copy read-only).
3. Another related program might have marked the file as read-only. Try closing other programs not needed but might have access to the file you are working on.
4. Programs that run across some errors automatically opens files in debug mode. Running the program again might create hidden resource conflicts. Close all your programs then re-start your computer.
5. Other users in your network might have opened the file for exclusive access so all others using that file will get a read-only copy. Try to re-open it again some time later.
Generally: Doing an operation to an already open file usually results to some conflicts/errors: for example deleting your document in Windows Explorer fails when you have the document already opened by another program.
Answered By 5 points N/A #154553

Error 46 that ‘Operation to a read-only file denied’


Hi Corey,

You are not able to access the file because the file is locked.

1. Start Windows Explorer,

2. Right click on Data directory,

3. Select Properties,

4. Unselect the read only box,

5. Go to command prompt,

6. Type command –r –s –h,

7. Reboot the computer where data file resides.

You need to be sure that each DacEasy user has admin rights.

I think this shall resolve the issue.

Login/Register to Answer

Related Questions