Error 1935 error occurred installation of assembly Microsoft VC90.ATL

Asked By 0 points N/A Posted on -


I get the following error when I try to install AVG 2012.

I tried various solutions for months but nothing was unable to gain by those things.

Finally I'm trying this help system.

"Severity Error
Error code: 0xC0070643
Error Message: General Internal Error.
Additional Message: Installing 3rd party redistributables failed. If Windows update is prepared on your computer, install it, if Windows update was installed recently, verify, please, its successful completion. Try to install AVG then again.
Error 1935. An error occurred during the installation of assembly 'Microsoft.VC90.ATL, version='9.0.30729.4148', publicKeyToken="1fc8b3b9a1e18e3b", processorArchivetecture="x86", type="win32", Please refer to help and support for more information. HRESULT: 0x80070002.
People say this may be a Windows Update error.
I tried several link to Microsoft Support, Ran some fixes but everything are in vain.
Can I solve this without formatting my machine?
Kindly need help.
Thank you.
Answered By 0 points N/A #82088

Error 1935 error occurred installation of assembly Microsoft VC90.ATL


Hi Mamoon,

The 1935 Error usually occurs when the MSI files are trying to install policy files on your computer during a setup operation.

To solve this problem here are two solutions to try:

First-Repair your .NET Framework installation:

1) Go to your control panel then choose programs and features then find your .NET version installed then click  uninstall/change button .

2) At this point you will see the option of repairing your .NET Framework and restoring it to original state, choose that option to start the repair process.

  • If you encounter any problem repairing your .NET Framework then you can choose to uninstall it completely and then download the latest .NET version from the internet and installing it.

Second-Unregister and reregister Windows installer:

1) click Start > all Programs > Accessories

2) Right click on Command Prompt and choose Run as administrator

3) Type "msiexec /unreg" and then type "msiexec /regserver"

Login/Register to Answer

Related Questions