Cannot access internet through Chief Architect X5

Asked By 35 points N/A Posted on -


I have been getting this cannot connect to the internet error every time I try to access the internet through Chief Architect X5. I checked my ADSL connection to ensure that it is working as usual and that the speed is good too. Then I tried accessing internet from my Firefox browser and find that I am connected to internet and can download files without any issues. It is only when I try to access using Chief Architect that I encounter this problem. I am using windows 8 on my machine and Firefox is my default browser. I attempted updating Firefox and tried accessing internet from Chief Architect. This did nothing to improve my situation. I have administrator access on this machine with full permissions. What could be the wrong then? I don’t have any more ideas. Please can anyone suggest a method to fix this issue? Thanks in advance.




Cannot connect to the internet. Make sure you have a default internet browser installed and that you are able to access the internet through it.

Answered By 590495 points N/A #182632

Cannot access internet through Chief Architect X5


Though you are already using Windows 8, make sure you are using the x64 version because Chief Architect X5 doesn’t run on x86 Microsoft Windows 8. For the complete requirement on specific operating systems, Chief Architect X5 supports Windows Vista, Windows 7, and Windows 8 all should be 64-bit. Other than that I don’t see any problem.

To make it clear, the system specifications for Chief Architect X5 doesn’t specifically mention a particular web browser that it will be supporting so I guess any web browser that can connect to the internet will do. If you can connect your web browser and visit any websites then there is really something wrong with your application.

Try adding it in the Exceptions list of Windows 8 maybe it’s Windows Firewall that’s blocking it from gaining outside connection. To do this, go to the Start menu and search without quotes “firewall” then click Settings. See image.

Click Windows Firewall on the next screen. See image.

In Windows Firewall, click “Allow an app or feature through Windows Firewall”. See image.

In “Allowed apps”, click “Change settings” and then click “Allow another app” at the bottom of the page. See image.

Select Chief Architect X5 in the list of programs and click Add. Once added, make sure Chief Architect X5 is checked and then click OK. Try running Chief Architect X5 again and see if it works.

Related Questions