Failed to Load on EAC3TO

Asked By 0 points N/A Posted on -

I am trying to find some ways to convert DTS-HD MA 7.1 to 8 WAVS files. I tried it with eac3to but it fails. I found a site and recommends pasting ASAudioHD.Ax and some other DLL files on the eac3to folder and then run the regsvr32 "path_to_eac3toASAudioHD.Ax on the Command Prompt. So I did what it says, but an error prompts me stating:


The module "" failed to load

Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files.

The specified module could not be found.


I lost in touch with the site and so I needed help. Please send me some solutions on how to continue with the process. Or send me new suggestions. Thanks.

Answered By 577085 points N/A #120770 Failed to Load on EAC3TO


It could only mean that the file you added and tried to register using the tool “regsvr32” is not compatible with the application or it could also be a problem in the path you specified when you run “regsvr32”. Running this tool requires a little knowledge on using DOS commands. If you want to run the “regsvr32” tool again, you should check the correct path of the file “” and not only rely on adding the path “path_to_eac3to” as recommended in the website.

Run the “regsvr32” tool again and this time specify the correct path to the file instead of just adding “path_to_eac3to” to the path. Try this method but you need to download and install ArcSoft TotalMedia Theatre Once installed, open Windows Explorer and go to the installation folder of ArcSoft TotalMedia Theatre in “C:Program Files”.

Find and copy the following files to “C:WINDOWSsystem32”:

  • checkactivate.dll
  • dtsdecoderdll.dll
  • MagCore.dll
  • MagPCMac.dll
  • MagUIEngine.dll
  • MagUIInter.dll

After that, register the file again like this “regsvr32”.

Login/Register to Answer

Related Questions