USB device not recognized Fujitsu ScanSnap S1300i Mobile

Asked By 60 points N/A Posted on -
qa-featured

Hi!

I am trying to install my new scanner for my desktop computer. The scanner is Fujitsu ScanSnap S1300i Mobile. The procedures we are following was from the manufacturer itself. We installed properly the software and driver provided by the manufacturer. We connected the USB device on the time it asked us to do so. We tried to run a test with it but by the time that we connected it showed device not recognized. Is it scanner issues or with my computer’s USB port? Can you help us resolve this issue? Thank you!

SHARE
Answered By 0 points N/A #193376

USB device not recognized Fujitsu ScanSnap S1300i Mobile

qa-featured

Hello,

If the USB port is buggy or the device is not working properly, this problem might occur.

First of all, unplug the USB connection, wait for about 2 minutes and then plug the USB connection in. If that didn’t fix the issue, change the USB port. If using any USB cable, then plug in into the port directly.

Restart your PC. Sometimes, system become jam-packed and can’t function well. Restarting the machine will fix it and increase its performance.

Download and install the latest driver and software for your scanner from here. Before installing the latest one, don’t forget to uninstall the old installation.

If still no solution, try the following:

1. From Start menu, type “device manager” >> hit Enter.

2. Expand “Universal Serial Bus controller”.

3. Right-click on each >> select “Uninstall”.

4. Restart your PC.

Now, your problem should have been solved.

Login/Register to Answer

Related Questions