Unable to view pictures on my MacBook

Asked By 40 points N/A Posted on -
qa-featured

Hello all, Recently I decided to send my MacBook for a backup and I sent it to a local apple store. After a few days, I was trying to view some pictures that I have on an external drive. But only a few pictures could be opened. When I clicked on the rest, it showed a message that I do not have the permission to open the document and that I need to contact the computer or network admin. This actually makes no sense because being the only user of my Mac, I am the admin. What is this all about? Please help! Thank You!

SHARE
Answered By 0 points N/A #181195

Unable to view pictures on my MacBook

qa-featured

Happy to support you!

It can be that the photos have not been properly backed up in iCloud.

But sometimes the photos may have got backed up in iTunes, if you had done a synchronization or a back up earlier. So, it is advisable to try to connect to iTunes & restore the latest back up available (but you may lose the changes done meantime).

Also, it can be that some issue (such as some changes in device settings) has occurred during the process of back up done by the local store. So, you can try contacting the store for any inquiry regarding the problem, since it occurred only after the back up.

 

Answered By 562905 points N/A #181196

Unable to view pictures on my MacBook

qa-featured

If this happened unexpectedly and you are the admin on your computer, check if the admin privileges have not changed. Right-click on your external hard drive then select Get Info. Click “Sharing & Permissions” to expand. Check the admin privileges. It should be set to “Read & Write”. If it is set to a different setting, change it to “Read & Write” by clicking the small up and down arrow beside it to restore the read and write capability of the admin account.

In case you cannot change the permissions on your external hard drive, check the format of your external hard drive. You can check it in Format under General section. Your external hard drive should be using Mac OS Extended [Journaled] to be able to set the proper privileges. See the image above. If your hard drive is formatted with NTFS then it will be set as read-only in Mac OS X.

Reformat your external hard drive. Backup your files first. Open Disk Utility then select the external hard drive. Select Partitions tab then click the dropdown menu under Partition Layout and then change to 1 Partition. It should display Mac OS Extended [Journaled]. Click Options near the bottom of the window, change to GUID, and then click OK. Click Apply and then wait for a few minutes. Your hard drive is now formatted with Mac OS Extended [Journaled].

Login/Register to Answer

Related Questions