Unable to play game after installing Direct X 11

Asked By 40 points N/A Posted on -
qa-featured

 

Hello,

Operating system Windows 7 has been installed in my system.  I installed a game and it was running perfectly fine on my PC. Then, I installed the Direct X 11 on the system. After this, I am having a problem while playing my game.  It was working perfectly fine before, but now, I keep on getting the following error on my screen:

'Setting Fail: Direct X device error'

My game is continuously crashing and I am not able to play it at all.

This happens when I am playing with my old characters. I started a new game with a new character, but I was unable to even purchase the skills for that one. The Ok button was not highlighted. So, I couldn’t  press it.

I tried by all means to resolve this issue, but I failed. I posted this problem to many forums. I found a solution on one of the forums, which was to force re patch the game. Following these instructions, I deleted the files and then tried to upload the game again, but the same Direct X device error  is seen on my screen.

I have tried to reinstall the game by using different downloading softwares, but the problem is still there.

I cannot figure out  the root cause of the issue.

If anybody can be of any help to me, I'll be really thankful.

Regards.

SHARE
Answered By 0 points N/A #152407

Unable to play game after installing Direct X 11

qa-featured

 

Hi Bryan,

First of all try to update your graphic drivers. Because there will be some in compatibilities of DirectX 11 with old drivers. Also you have to consider what the Windows 7 service pack installed on it is. If there is no service pack then download or update your system to Service Pack 1. After doing above two updates then give a try to install DirectX 11. Don’t forget to see the specifications of your graphic card. And finally check whether you have sufficient memory installed on your machine.

Hope this is helpful

Login/Register to Answer

Related Questions