Site works on debian but not on OpenSUSE

Asked By 30 points N/A Posted on -
qa-featured

Hello people, 

I always have problems with OpenSUSE, but unfortunately I'm not allowed to take it off the server … My problem is this, I have a site hosted on an OpenSUSE, with a "Guestbook" on the site, which does not use the database, this book records all in one file. "txt". 

In debian this book works perfectly, as the message posted on OpenSUSE does not work, I used the same book in two OSes, just copied OpenSUSE for debian and it worked … I permission that I gave to the file was "chmod 666-name file.txt" … 

In debian I had not given any permission and when I post the message, it complained that I could write the file, since openSUSE does not say anything … Maybe wrong php5 OpenSUSE or something?

Best Regards,

Garry kirtsen

SHARE
Answered By 0 points N/A #196066

Site works on debian but not on OpenSUSE

qa-featured

Hi,

This type of installation is used by DSO (module). There is another way of installation. 

Step 1: Download the tar file containing the source code of Apache and PHP: apache_1.3.26.tar.gz php-4.2.1.tar.gz

Step 2: Unpack them: # tar -xzvf apache_1.3.26.tar.gz # tar -xzvf php-4.2.1.tar.gz

Step 3: Configure, Compile and install Apache: # cd / apache_1.3.26 #. / configure -prefix = / usr / local / apache / -enable-module =so # make # make certificate TYPE = custom # make install

Step 4: Start Apache: # / usr / local / apache / bin / apachect / restart

Step 5: For Apache, PHP need two modules. "http_core.c" and mod_so.c". To make sure they are installed, type: # / usr / local / apache / bin / httpd-I / If any of these modules is not present in the list of Apache module, recompile with the option "-enable-module = [module name]."

Step 6: Get the path program apxs (Apache extension tool) : # find /name "apxs"

Step 7: Here is the apxs = / usr / local / apache / bin / apxs # make # cd / usr / share / php -4.2.1 # configure -with-mysql = / usr / local / mysql-with-apxs = / usr / local / apache / bin / apsx # make # make install # cp php.ini-dist / usr / local / lib / php.ini

Note: If the version of Apache is 2, you must use the -with-apxs2

Step 8: Edit the file configuration of Apache, the httpd.conf:# vi / usr / local / apache / conf / httpd.Conf Enter/ Verify the Lines: AddType application / x-httpd-php DirectoryIndex Index.Html Index.Htm index.Php LoadManual Php4_module libexec/libphp4

Step 9: Restart Apache: # / usr / local / apache / bin / apachect / restart

Step 10: To test create a info.Php # vi / usr / local / apache / htdocs / info.php E insert the lines: <? php phpinfo();"?> Save and access.

This will solve the problem.

Waters Magner

Login/Register to Answer

Related Questions