Qmail refuses large attachment in email

Asked By 0 points N/A Posted on -
qa-featured

Hi there, experts,

I have a few questions regarding Qmail. I have a client who wants to send an email with a large attachment than usual. Unfortunately, the email is refused with the following error message: 

Protokoll: SMTP, Serverantwort: '552 5.3.4 Error: message file too big', Port: 25, Secure (SSL): Nein, Serverfehler: 552, Fehlernummer: 0x800CCC6D

It might be helpful to know that the maximum file length in the configuration is placed way ahead of the length of the attachment. I have also altered the settings of Plesk mail configuration in the hopes of solving the problem. 

I have yet to see an effective solution for this predicament. I tried deleting the affected packages in version 9 and I even upgraded the version 9 to 10 but these did not do anything.

The weird thing here is that I can send the same email with the same attachment size using my personal email address under the same server. 

Can anyone explain this to me?

We need your answers.

Thanks.

SHARE
Answered By 0 points N/A #93294

Qmail refuses large attachment in email

qa-featured

File attachment size in Qmail for both sending and receiving is unlimited. It was preset in your application. However, you might have changed the file size capability.

So change your setting to bigger file size. It will solve your problem. You can increase your file size by running the command: echo "XXXXXXXX" > /var/qmail/control/databytes. Here XXXXXXX is the amount of  maximum kilobytes you want to set up.

However, remember that if you have set up the maximum file size of 15 MB, it may be rejected sometimes though the file was 15 MB or less. Because if a file is Base64 encoding then every 3 bytes will be turned to 4 bytes and the legal file size will increase 25%. So if you attach a file of 15 MB it will be 18.75 MB.

I think you can solve your problem now.

Login/Register to Answer

Related Questions