PowerIso Virtual Drive prompting for installation error

Asked By 70 points N/A Posted on -
qa-featured

Hi.

I am using PowerIso 4.4 and 4.5 and I'm facing this error message:

''PowerIso Virtual Drive is not installed correctly.  Please reinstall it''.

The program was functioning properly some days ago.

To resolve this, I uninstalled it and then installed it back, but nothing changed.

Please help me solve this.

Thanks a lot.

SHARE
Best Answer by Sharath Reddy
Answered By 0 points N/A #96756

PowerIso Virtual Drive prompting for installation error

qa-featured

There is always a problem while using such software in virtual machine. The reason behind this is that you need to install the drivers for it separately. There are a few versions that are released with preinstall drivers and you need to download them. However,you can still try by downloading the latest version of the PowerIso and running it.

The stable version that I am using is this one. You can download PowerISO 4.4. This one does not need any virtual device drivers to run properly.

If you are using Windows Vista or Windows 7, then run the setup as administrator by right clicking on it and selecting the required option.

Best Answer
Best Answer
Answered By 565040 points N/A #96757

PowerIso Virtual Drive prompting for installation error

qa-featured

I think the reason for having this error is because of its version. If you already reinstalled the product and still nothing happened, you should check if after uninstalling it its installation folder was also removed. Because there are times uninstalling applications doesn’t remove the folder where they are installed and this is very common.

Some of the corrupted files might still be in there and installing it back will not delete these files and will only allow the program to still reuse them instead of replacing them with the default files from the installer.

Try reinstalling it again and see if the folder was also deleted. Uninstall the program then browse to “C:Program Files”. Check if the program’s folder is still visible.

If the folder was not deleted, delete it manually and then restart your computer. If the system doesn’t allow you to delete it, restart your computer. After booting go to “C:Program Files” again then delete the PowerISO folder. Next, install PowerISO again then see if it works now.

If still doesn’t, download and install the latest version from Power ISO – All in one solution Download PowerISO.

Login/Register to Answer

Related Questions