Popping Security Information on my browser

Asked By 190 points N/A Posted on -
qa-featured

Hi,

I am using Internet Explorer 7 as my default browser. This Security Information box keeps popping whenever, I visit any secure site. And it's really annoying especially when I am in a rush to finish something.  This pesky warning is appearing more often now. It appears on almost every site I go to. Even in my Hotmail or Gmail account.

 I searched on different sites for a fix and followed thoroughly. I clicked on Tools then I clicked the Security tab. The Internet is highlighted, and I clicked on Custom Level Button below. On the Miscellaneous Section, I enabled the display mixed content, then hit okay. But I am still receiving the same security box.  Is this really important?

This is the content of the security box;

This page contains both secure and non secure items.

Do you want to display the non secure items?

[Yes] [No] [More Info]

I always choose the yes button, and it will continue with the site. I don't remember trying to click the no button or the more info button. Anyway, I just want to know if this is really needed, I will just let it stay popping on my screen.

Any help will be appreciated.

Thank you.

SHARE
Best Answer by stuart kn
Best Answer
Best Answer
Answered By 0 points N/A #126786

Popping Security Information on my browser

qa-featured

Usually, this type of a message box pop-out when you navigate from “https” page to “http” page.

Sensitive information such as credit card information entered to a non secure web page (i.e. pages that begin with http), can be accessed illegally by a third party group, and if it is disabled, the warning message won’t  pop-up and therefore sometimes you may not aware of the security of the information that you are submitting .

In order to remove this, Do following in Internet explorer options

1. In the main menu, click on “Tools” and click “Internet Options”.

2. Under the "Security" Tab, click the "Custom Level" button.

3. Under the "Display mixed content" category in settings, select the option "Enable" and then click OK.

4. "Security Warning" message box pop-out. Just click “yes” and then click “ok”.

6. Close Internet explorer, reopen and check.

To protect your sensitive information submitted via web pages always check whether the site begins with https:// where you can guarantee information sent are encrypted. 

Refer below image for more information.

 

Answered By 190 points N/A #126787

Popping Security Information on my browser

qa-featured

Amazing! This one worked with me. I am so thankful to you. Thanks a lot.

Login/Register to Answer

Related Questions