McAfee Anti Virus makes my computer slow

Asked By 210 points N/A Posted on -
qa-featured

Hello! Everyone,

I have a problem with my Antivirus program. I hope somebody can help me. My computer is running on Windows Vista SP2. My HDD is 40GB, 2.0GHz. Even though my HDD is only 40GB, I do not have much files in my computer as well as applications because I am using my computer mostly on the internet. Now, my Antivirus software is McAfee.

At first, I thought my browser is what makes my computer slow. so, I cleared cache, cookies, files and histories on my internet options. Unfortunately, the same slow connection persisted. Then I decided to check my "Task manager". That’s when I realized that McAfee consumes a lot of memory in my active processes.

When I tried to exit McAfee, I don’t experience a slow connection. Is there something I can do about this without removing McAfee?

Or do I really need to get rid of it.

Appreciate if somebody can help.

SHARE
Best Answer by Aimee1
Answered By 0 points N/A #112765

McAfee Anti Virus makes my computer slow

qa-featured

Hello!  Dear Sarah Gardens

You are right!  The McAfee is consuming most of your process. If you wish to get the faster performance you need to change the Antivirus. In this case the kaspersky also puts a burden on your computer which results a slower performance to it. So you can change your Antivirus like to Avast or AVG. These two Antiviruse's are really user friendly and never decreases your performance while keeping the system secured.

Have a nice time.

Best Answer
Best Answer
Answered By 0 points N/A #112766

McAfee Anti Virus makes my computer slow

qa-featured

Dear Sarah Gardens,

This is a common problem while using McAfee Antivirus and the major problem is that by default every time you start your PC McAfee gets instructions to scan your whole computer which eventually causes your computer software to perform slowly. You should change its default settings to scan from every time towards scheduling to some specific time intervals when you feel you don’t have many tasks to perform.

  1. Go to  Advance menu
  2. Configure 
  3. Computer and files
  4. Advance
  5. Schedule scan
  6. Enable schedule scan
  7. Select day and time you want to schedule scan
  8. Apply changes.

This will solve your problem.

Login/Register to Answer

Related Questions