Localhost is not working Properly.

Asked By 0 points N/A Posted on -
qa-featured

I install XAMPP server in my system. I want to use this software for PHP and database work. After installation I restart my system then I start MySQL and Apache. Now I want to access localhost through my browser. But I can’t access localhost. Please tell me its reason.

SHARE
Best Answer by jhon clark
Best Answer
Best Answer
Answered By 0 points N/A #120873

Localhost is not working Properly.

qa-featured

There are few reason through which you are unable to access your localhost. You have to follow these steps this might help you. First you have to uninstall your Xampp. And download the latest version of Xampp and install it on your local machine. while installing.

You have to keep in mind that check all boxes which appear in the installation for the Apache server and MY SQL server. When you finish installation start your Apache and My SQL server. If it does not start. Check their respective ports. the default port for the Apache server is 80. If the Xampp server gives the port busy message. Change the port number for these servers for example if you have changed the port number from 80 to 81 then you can access it like. localhost:81

Write this in your browser "localhost" then full colon (:) and then the port number and enter .

This will access you localhost.

Answered By 0 points N/A #120875

Localhost is not working Properly.

qa-featured

If the local web server is running on XAMPP, you may encounter this error that Apache cannot be started. The symptom is as follows. When you click Start in control panel of XAMPP, the green message of ‘Running’ appears only one second then disappears. And eventually Apache does not start.

There may be  two causes for this error.

Firstly, any other application e.g. Skype is using your pc port 80. You can examine this by following these steps.
Open Skype >>Click Tools >>Opions>>Advanced>>Connection.
Examine whether ‘Use port 443 and port 80 as alternatives’ option is clicked. If this option is clicked, then un-clicked it. And you have to confirm that the port number is not 80.

If port 80 is not occupied by Skype and you have to find out what application is using it. Open Windows XP command prompt.
Click Start >> Run >> Type in ‘cmd’ and press Enter.
Type in ‘netstat -a -no’ and press Enter.
Search 192.168.1.100:80 or 127.0.0.1:80. If either one is present, then port 80 is occupied.
Write down the Process ID value. Then search this PID in command window by typing tasklist…. and Enter. Then the .exe file occupying that port should be found.
If you don’t know the file name, try to Google it.
Open Windows Task Manager and end this task (at your own risk).

Secondly, the php.ini file has an conflicting value or invalid value so that Apache does not start. As such, you may wish to replace your existing file with XAMPP default copy. You can find it in folder named /xampp/apache/bin/. Another copy could be found in folder of /xampp/php/. Or you can try to undo the recent changes in php.ini.

If above both are not the cause of error, then you may wish to look at Windows Event Log. This could be panic.

Hope this can be helpful. Good luck.

Login/Register to Answer

Related Questions