LaCie 2Big external hard drive error mounting problem

Asked By 10 points N/A Posted on -
qa-featured

Help!

I have a LaCie 2Big external hard drive. When I tried to access it this error came.

I tried shutting down my computer and unplugged the USB cable, turned it on then plugged it back in, but when I accessed it still it likes to show of its big error message with hint's that I don't even understand.

What should I do?

I don't know if this helps, my operating system is Linux.

Unable to mount LaCie 2Big

Error mounting: mount exited with exit code 12: Failed to read last sector (1953519615): Invalid argument

HINTS: Either the volume is a RAID/LDM but it wasn’t setup yet, or it was not setup correctly (e.g. by not using madams – build …), or a wrong device is tried to be mounted, or the partition table is corrupt (partition is smaller than NTFS), or the NTFS boot sector is corrupt (NTFS size is not valid). Failed to mount ‘/dev/sdc1’ doesn’t seem to have a valid NTFS. May be the wrong device is used? Or the whole disk instead of a partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

Regards,

Jay

SHARE
Best Answer by Cohen Wible
Answered By 0 points N/A #171228

LaCie 2Big external hard drive error mounting problem

qa-featured

Hello,

There might be a problem with the driver related to your external hard drive. The connection driver might have been corrupt. 

Try to uninstall the driver related to the drive and restart your system. 

After restarting try to install the driver again and connect your hard drive.

This should solve your problem.

Thank you.

Best Answer
Best Answer
Answered By 0 points N/A #171230

LaCie 2Big external hard drive error mounting problem

qa-featured

You might be using a Mac operating system, and one way to check this problem is locating if there are problems with your cable, or if the software associated with your device is damaged.

If the cable is damaged, replace it with a new thunderbolt cable.

If the software is damaged, reinstall it with the application software included with your device.

I have provided a link for your troubleshooting needs below:

http://www.lacie.com/products/product.htm?id=10573

Login/Register to Answer

Related Questions