Invisible X proj and Y proj columns while using gps plug ins

Asked By 10 points N/A Posted on -
qa-featured

 

Hello friends,

I have recently started using qgis 1.7.4 with New Zealand traverse Mercator as CRS (espg 2193). I am using this to create a gpx file from a shape file containing points. The CRS is fixed for my project and the layer as well.

When I use the gps plug-ins, 3 layers within the project are created namely waypoints, tracks and routes. When I see the attribute table for the waypoints, the X Proj and Y Proj columns are not visible to me, whereas, I need these both columns for GPS. They are present in the original shape file, but why aren’t they visible on the table? The table seems to be completely empty.

The only option that I could think of was the "save as" option. By using this option on the shape file layer, which has the attribute GPX_USE_EXTENSIONS=YES, my issue is solved to some extent. I get the full data file, but unfortunately, when I try to upload it with qgis as a shape file, I don’t get my X Proj and Y Proj columns as fields and the associated projection is explained as +proj=longlat +datum=WGS84 +no_defs.

The other option was to use DNRGarmin to open the files, I tried using it, but each time, I was met with an error. The screenshot of the error is as follows:

System Error #1901340159

DNRGarmin

Projection Error [1901340159]: System Error #1901340159

                                       OK

When I press OK, I get both the columns of X proj and Y proj, but they are filled with the latitudinal and longitudinal fields.

Has anyone else encountered this problem? I have searched a lot for the solution and spent a lot of time trying to resolve it, but now, I am at my wits end.

During my search, I concluded that creating shape files directly with DNRGarmin to open with qgis is a far better option as compared to importing gpx files in qgis.

Your suggestions are awaited.

Thank you for your time.

Regards.

SHARE
Answered By 0 points N/A #150927

Invisible X proj and Y proj columns while using gps plug ins

qa-featured

Hi Hardin, it is possible that the HD72 project definition in DNRGarmin doesn't have the correct parameters. If you have ArcMap installed, you can select the "Arcmap" option in the set projection window and then load a PRJ file for your protection using the LoadPRJ button.

You can download Arcmap from here:

I hope this information is of great assistance to you.

Login/Register to Answer

Related Questions