Google keeps redirecting from a different website

Asked By 200 points N/A Posted on -
qa-featured

Every time I search the Internet using Google and then click a result, I get directed to a website that is completely irrelevant to my keyword. The webpage that I am directed to is not even the same website showing on the search results page.

It’s like Internet Explorer has a mind of its own. Any ideas what could be causing the problem?

SHARE
Best Answer by Abdul Salim
Answered By 0 points N/A #86928

Google keeps redirecting from a different website

qa-featured

Are you getting pop up windows when you open Internet Explorer? What programs did you recently installed programs? It is possible that you have malicious software installed on your computer.

Answered By 200 points N/A #86929

Google keeps redirecting from a different website

qa-featured

No, I am not getting pop up windows on Internet Explorer. Last program I installed is the Mesh Toolbar.

I also scanned my computer for viruses and detected none.

Thank you for your reply,

hope you can help me further.

Best Answer
Best Answer
Answered By 0 points N/A #86931

Google keeps redirecting from a different website

qa-featured

Some toolbar may cause issues with your Internet Explorer. I suggest that you uninstall or disable this toolbar to make sure that this is not the culprit. You can do this by going to the control panel and then Uninstall programs. Also, try clearing cache and deleting cookies. It is possible that you have corrupted Internet files stored on your browser that is causing the issue. You can optimize your Internet Explorer settings by following these steps:

1.  On Internet Explorer, click Tools and then select Internet Options.
2.  On Browsing history, click Delete.
3.  Make sure that the Temporary Internet files and Cookies boxes are selected.
4.  Click the Delete button and then hit OK.

Answered By 0 points N/A #86932

Google keeps redirecting from a different website

qa-featured

I also suggest that you enable the "Every time I visit the webpage" Option. These steps will you’re your Internet Explorer load fresh copy of webpages in to your computer.

Here’s how:

1. On Internet Explorer, click Tools and then select Internet Options.
2. On the General tab, select Settings under the Browsing history.
3. Look for the Every time I visit to webpage option and make sure it is selected.
4. Click the “OK” button.

Answered By 200 points N/A #86934

Google keeps redirecting from a different website

qa-featured

I tried using Google Chrome and I am not experiencing the same issue. I think it is best if I’ll stick with Chrome for a while and go through the steps you provided some other time. I guess you’re right, the toolbars installed on my Internet Explorer are the ones causing the issue. I have several toolbars and I will definitely uninstall all of them once I have the time. Thank you for all your suggestions they were really helpful.  

Login/Register to Answer

Related Questions