How to configure the WCF to be compatible to IIS7 system?

Asked By 0 points N/A Posted on -
qa-featured

Hello there, I upgraded my machine to IIS7 (Window Server 2003) from IIS6 (Window Server 2008), when I tried to transfer the Window Communication Foundation to IIS7 (Window Server 2008), it did not integrate as expected but instead returned an error window.

How can I configure the WCF so that it becomes compatible to IIS7 system?

Help me in this please.

Error:
Server Error in Application "Default Website"
HTTP Error 500.24-Internal Server Error
An ASP.NET setting has been detected that does not apply in Integrated managed pipeline mode.

Detailed Error Information

Module: ConfigurationValidationModule Requested URL http://localhost:80/

Notification: BeqinRequest Physical Path C:inetpubwwwroot

Handler StaticFile Logon Method: Not yet determined

Error Code 0x80070032 Logon User Not yet determined

Most likely causes:

• system.web/[email protected] is set to true.

Things you can try:

• If the application supports it, disable dient impersonation.

• If you are certain that it is OK to ignore this error, it can be disabled by setting system.webServer/validatiorival.dateIntegratedModeConfiguration to false,

• Move this application to an application poo’ using Classic NET mode – for example, %SystemRoot%system32lnetsrvappcmd set app "Default Web Site " /appllcatlonPool:”Classic .NET AppPool”

"You can set Classic NET AppPool to the name of another application pool running in Classic managed pipeline mode)

SHARE
Answered By 0 points N/A #155505

How to configure the WCF to be compatible to IIS7 system?

qa-featured

Hello Catherine,

500.24.50 Error occurs because ASP.NET Integrated mode is unable to impersonate the request identity in the BeginRequest and AuthenticateRequest pipeline stages. 500.24 is thrown if your application is running in integrated mode, validateIntegratedModeConfiguration is not declared or set to TRUE, and your application has identity impersonate set to TRUE.

Follow below steps:

1. If your application does not rely on impersonating the requesting user in the BeginRequest and AuthenticateRequest stages (the only stages where impersonation is not possible in Integrated mode), ignore this error by adding the following to your application’s web.config:
  <system.webServer>
          <validation validateIntegratedModeConfiguration="false" />
  </system.webServer>

2. In case your application rely on impersonation in BeginRequest and AuthenticateRequest, or you are not sure, move to Classic mode.

3. Remove from web.config which won't be effective in integrated mode anyway

Thanks
Divina

Login/Register to Answer

Related Questions