No of visitors who read this post: 4389
Type: Question
Author: Alexrods
Your rating: None Average: 5 (1 vote)

Hi,

When I was at home doing some research work, I came to a point that I need some exact geographic coordinates of a certain area. My friend advised me to use Google Earth. So, I installed it in my computer, when I was about to use it an error appeared on my computer that tells me "We were unable to connect to the Google Earth servers to activate your account."

We were unable to connect to the Google Earth servers to activate your account.

For information about how to resolve this problem, would you like to run a diagnostic test? This test attempts to detect settings on your computer that might prevent Google Earth from functioning properly.

After I read the long error message, I immediately check my internet connection. All was up and running since I can browse the internet. I checked on my firewall and there was no restrictions. Please help me to find solution on my problem.

Thanks.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 16526

Dear you should have to check first your settings of Google Earth.   Are they same as you are using previously, if they are fine and still you are unable to connect with the servers than you should run up some test regarding the connection to servers. The Google provide a customer help website from which you can easily analyze about your PC that may it be able to connect with the Google servers or not.

REGARDS

FAYE

# Comment Id: 19146

 Hi Alexrods,

  • The Google Earth setting requires that you do not have a software firewall, otherwise even disabling antivirus and anti spyware cannot still rectify the problem. Therefore, the most probable working solution you need to apply in this situation is go to the system registry and delete the 'google earth plus' entry. This is illustrated as follows:
  • Go to 'Start' button > Run(type in regedit) > An explorer bar appears> Go to 'HKEY_CURRENT-USER-> SoFTWARE > GOOGLE EARTH PLUS. Delete 'GOOGLE EARTH PLUS'.
  • You need to later uninstall and reinstall Google Earth. The kh_pro should be set as a valid user agent within your proxy settings. Ensure that the proxy permits access on port 80. You may also try to disable your proxy server.It should solve the problem.