“General Error” message when printing on Epson Stylus C59

Asked By 0 points N/A Posted on -
qa-featured

I have just changed all four ink cartridges (C-M-Y-K) on my Epson Stylus C59 printer.  The physical installation was successful up to the point when the printer finished charging the ink.  The Maintenance LED on the Maintenance button started blinking red continuously.  Whenever I print, the status monitor pops up with a message "General Error", and I can no longer print anything.

I've checked for jammed paper or objects but there were none. I've tried restarting my computer and the printer, clearing the print job queue, and even putting in another new set of Epson original cartridges in the right manner. The problem still persists. How can this be fixed?

Epson General Error

Delete all print jobs and turn the printer off. Remove any foreign objects from inside the printer. After a few minutes, turn the printer back on.

SHARE
Best Answer by Leslie Mark
Answered By 0 points N/A #129003

“General Error” message when printing on Epson Stylus C59

qa-featured

Hi there,

All you need to do is follow these simple steps (but do the steps with caution)

  • Pull the power cable of your printer
  • Push the power button
  • After pushing the power button, you may click maintenance
  • After which you need to press stop.
  • After doing the steps, plug the power cable again to your printer

Have a nice day!

Answered By 0 points N/A #196984

“General Error” message when printing on Epson Stylus C59

qa-featured

Hi,

Try checking for unfinished activity of the printer by >>going to MS Word >>type anything you want >>Ctrl+P to print. Then if what's in your screen different from the one that is printing cancel quickly the printing process. It means that, there is an unfinished activity that is why you are experiencing this kind of problems, after doing this you can get rid of the problem. If not try downloading the installer of the printer designated for Epson C59 printer hardware, in EPSON Official website.

Example:

Step 1:

Step 2: Select your OS

Step 3: Click here

Step 4: Accept

Best Answer
Best Answer
Answered By 0 points N/A #196987

“General Error” message when printing on Epson Stylus C59

qa-featured

I think it may work for you because It works for me. Let’s try it:

Solution 1: At first remove the printer driver from control panel and the reinstall it. Try…

Worked!!! Not Worked…??

Solution 2: You can reset the chip easily with a software,

Get It now>>> Here: http://www.gigasize.com/get/j28xzkm2lmb

Download & Install it. It is very easy to do. (But careful about version 32/64bit OS)

Select the printer & minimize the window in Taskbar.

Then go to icon of this program, Right click on this & Select “PROTECTION COUNTER=RESET PROTECTION COUNTER”. (It is need to Unblock Printer)

At last click “ACCEPT” & power off printer and turn again.

Try……. It works!!!

Login/Register to Answer

Related Questions