Error When Playing in Windows Media Player

Asked By 40 points N/A Posted on -
qa-featured

Hello,

I am consistently getting following error message,whenever I try to play any video that should use WMP. "Windows Media Player cannot play the file because the specified protocol is not supported. If you typed a URL in the Open URL dialog box, try using a different transport protocol (for example, "http:" or "rtsp:"). (-1072885317)" I get WMP12 on Windows 7 and I, personally, searched too much on the net for a result. I individual proved uninstalling/installing WMP, spurting a dictation cypher and deleting enter (I got that from the semiofficial microsoft.com funding diplomatist), and also renaming a folder.

Null has worked and I'm so frustrated. I modify did a reinstall of Windows 7! When I run the code codification (regsvr32 wmnetmgr.dll) the video instrument fill but before it can play, something else pops up active my firewall blocking my video. But before I can flick the "Allow Access" option, the PC restarts itself. After the restarting though, it goes side to the original failure content. If anyone knows what to do/has anything variant suggestions additional than what I love already doing, waiting for your kind response!

Thank you!

SHARE
Answered By 0 points N/A #147513

Error When Playing in Windows Media Player

qa-featured

Hello Otis,

Try the following methods and see if they will help solve the issue that you are getting:

Method 1:

The issue could be occurring because the Wmnetmgr.dll file has not been registered incorrectly. Follow the following steps to resolve it:

  • On your computer click Start, and then type cmd, and then right click on cmd and then select Run as Administrator.
  • After that go to the command prompt, and then type regsvr32 wmnetmgr.dll, and then press ENTER.
  • And then exit, and then press ENTER.

Method 2:

You will need to check if Windows Media Player streaming video settings is enabled.

  • Open Windows Media Player and then click on Organize.
  • After that go to options and select Network tab.
  • And then go to the Network tab and then select all the check boxes and  try again.

Regards,

Carl

 

Login/Register to Answer

Related Questions