No of visitors who read this post: 596
Type: Question
Author: Rypatterson
No votes yet

Hello again, experts!

I have tried to compile and run Sweet Home 3D version 1.6 and 1.7 but I want to do it using Eclipse. I have a plan and I need to do some checking on the software.

In Eclipse, I can compile SW3D on Windows Vista Basic 32-bit operating system. However, when I want to run them as applications, I get the following errors:

20-Mar-2009 12:26:37 PM javax.media.j3d.NativePipeline getSupportedOglVendor SEVERE: java.lang.UnsatisfiedLinkError: no j3dcore-ogl-chk in java.library.path Exception in thread "Thread-2" java.lang.UnsatisfiedLinkError: no j3dcore-d3d in java.library.path at java.lang.ClassLoader.loadLibrary(Unknown Source) at java.lang.Runtime.loadLibrary0(Unknown Source) at java.lang.System.loadLibrary(Unknown Source) at javax.media.j3d.NativePipeline$1.run(NativePipeline.java:231) at java.security.AccessController.doPrivileged(Native Method) at javax.media.j3d.NativePipeline.loadLibrary(NativePipeline.java:200) at javax.media.j3d.NativePipeline.loadLibraries(NativePipeline.java:157) at javax.media.j3d.MasterControl.loadLibraries(MasterControl.java:987) at javax.media.j3d.VirtualUniverse.<clinit>(VirtualUniverse.java:299) at javax.media.j3d.Canvas3D.<clinit>(Canvas3D.java:3881) at com.microcrowd.loader.java3d.max3ds.Main.init(Main.java:121) at com.sun.j3d.utils.applet.MainFrame.run(MainFrame.java:267) at java.lang.Thread.run(Unknown Source)

I also tried to add the dll files in lib/windows since it's a class directory but it doesn't work. Moreover, I have used Ubuntu 8.10 in its place and Eclipse gives me four error messages, which stop it from compiling.

These errors are:

1. JEditorPane.W3C_LENGTH_UNITS cannot be resolved - HelpPane.java line 23

2. PrintMode cannot be resolved - FurnitureTable.java - line 437

3. The method setLocationByPlatform(boolean) is undefined for the type JFrame - HelpPane.java line 385

4. The method setLocationByPlatform(boolean) is undefined for the type JFrame - HomeFramePane.java line 323

I need your help.

Thanks!

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 47358

Dear Rypatterson

According to the error message u received in Windows vista 32-bit Operating system, did u try to "Open run Dialog" in eclipse and add to the Virtual Machine argument text field this option"-Djava.ext.dirs=lib;ib/windows" without the quotes. You'll find the Virtual Machine argument under the arguments tab.

For the error u received in Ubuntu 8.10 Operating system "JEditorPane.W3C_LENGTH_UNITS cannot be resolved - HelpPane.java line 23", it seems that u r using Java 1.4 instead of using Java 1.5 compiler. This appears from the error message u got, as the "W3C_LENGTH_UNIT" variable is available since version 1.5 only and so u got the "cannot be resolved" error.

Hope this may help you.

Best of luck