Problem with Photoshop “out of memory”

Asked By 0 points N/A Posted on -


I have a problem with my Portable Photoshop CS4 install in my computer. I am using Intel Core2 Duo CPU, with 2gb memory running Microsoft Windows XP Professional Version 2002, Service Pack 2. I've been using my Portable Photoshop for quite a while and I never encounter a problem. But since last week, it gives me and error "Out of memory RAM". I set the cache setting into its maximum level but same error I got.

Best Answer by Franks good
Answered By 0 points N/A #126957

Problem with Photoshop “out of memory”




If you are using Windows XP , then it means you are using 32-bit Version of Photoshop CS4.

Well, here is a solution for your problem:

1. Go to the dialogue box named "Performance Preferences"

2. Reduce the RAM memory allocation to Photoshop CS4.

 By default it will be 70%.

You should reduce it in increments of 5 and retest it. At some point you will get rid of the error.




Best Answer
Best Answer
Answered By 0 points N/A #126959

Problem with Photoshop “out of memory”




2 GB memory is a lot for Photoshop CS4. Sometimes it’s even showing error on laptops having 16 GB of memory. So if you are sure that it’s not memory problem then you should try deleting PERF’S file.

You can delete this file while PS is loading so when PS is loading hold CLTR + ALT+SHIFT.

This will allocate free memory for your PS because PS is really a memory hog.

I hope it will fix your problem.

You'll find it at Documents and Settings[user name]Application DataAdobeAdobe Photoshop CS4Adobe Photoshop CS4 Settings.


Answered By 574765 points N/A #126962

Problem with Photoshop “out of memory”


That problem is really a headache because it will cause Photoshop to immediately exit after launching it. If your computer is installed with 2 GB RAM then there should be no problem because Photoshop CS4 requires only a minimum of 512 MB RAM. Whether you are using the normal version or the portable version, they have the same system requirements.

Photoshop CS4 supports Windows XP Service Pack 2 or higher 32-bit only and Windows Vista (Home Premium, Business, Ultimate, or Enterprise edition) Service Pack 1 or higher both 32-bit and 64-bit. Microsoft Windows 7 is not officially supported.

It requires at least 1.8 GHz or faster processor, 512 MB RAM, 1 GB free hard drive space, 1024 x 768 screen resolution, video card with OpenGL 2.0 and Shader Model 3.0 support, DVD drive, and QuickTime 7.2 or higher. Since you have plenty of RAM to use, the first post is a good suggestion to adjust the amount of memory allotted to Photoshop.

In Photoshop 7.0.1, the default memory allotted to Photoshop is about 50 percent (50%). If Photoshop CS4 is defaulted to 70 percent (70%) of the physical RAM then that’s huge considering you only have about 2 GB RAM. Lowering down the value may fix the problem. Try doing a trial-and-error as you adjust the memory preference for Photoshop.

If this doesn’t fix the problem, try increasing the amount of pagefile your operating system is using. This can help in balancing the memory load of your computer. To adjust the size of the pagefile, right-click “My Computer” and select “Properties”. Select “Advanced” tab then click “Settings” under “Performance” section. Select “Advanced” tab then click “Change” under “Virtual memory” section.

In the “Virtual Memory” configuration window, if it is set to “System managed size” then you should change it. Select “Custom size” then specify the “Initial size (MB)” and “Maximum size (MB)”. Once the values are set, click “Set” and then “OK”. Just restart the computer when it asks you to do so.

The two values don’t have to be the same. I only use the same values because of its advantage. It prevents or lessens the fragmentation level of the drive where the pagefile is located. When you enter different values, the size of the pagefile constantly changes depending on the value you set for the “Initial size” and “Maximum size”.

This greatly generates huge fragmentation to the drive and affects the speed of data access.

Login/Register to Answer

Related Questions