Problem connecting to my home computer remotely

Asked By 200 points N/A Posted on -


We have an open office configured to accommodate about 20 computers. So recently, I moved the server from one location to a different one, but in the same room. At the previous location, I could use the remote connection (Desktop client version) on my home computer, which has Win XP Pro running to connect externally to Win 2K Pro, without a hassle. My Win 2K Pro machine uses two NIC cards.

In this case, I used the first one on my previous location where it worked just fine, while I am now using the second one at my current location and have this problem. When I tried to connect using remote desktop protocol (RDP), I encountered this error;


Remote Desktop Disconnected

Because of a protocol error detected at the client (code 0x1104), this session will be disconnected. Please try connecting to the remote computer again.

A colleague who had since moved to my previous location, can now connect to my home PC without any errors. After some research, I learnt the problem could be triggered, if another program was using the same port, that RDP was trying to use. But this is not the case, as I have no other program using that port, on my Win 2K Pro.

My server has only one default gateway.

Please help me out somebody?

Could the problem be caused by moving my machine?

I’ll appreciate any help.


Best Answer by rpesado
Best Answer
Best Answer
Answered By 0 points N/A #127467

Problem connecting to my home computer remotely


Hi Lincoln! I'm going to shed some light on why this happened and some very simple troubleshooting step/s.

It may be that:

  1. The terminal server is running an application, that uses the same port as the TS.
  2. The server comes with 2 NICs and each of them has a default gateway. This will mess up your routing table. No computer is allowed to have 2 default gates.
  3. The client has XP as a Remote Host with DHCP setup. The remote client will receive this error, when the Remote host IP changes.
  4. You moved your server to another location.

Look for a solution in Terminal Services Configuration. Authorize the second NIC to be used as RDP.

Hope I was able to help you with this problem.
Answered By 0 points N/A #127468

Problem connecting to my home computer remotely


Hello  Lincoln,

First of all, you will need to check the new location and see if it has a  firewall or maybe an IPS that may be blocking you from accessing RDP, for that may be a possible cause of the issue.

Otherwise you will need to get down to the basics, and leave out  VPN as well as  ISA for a moment. You will need to check if you can be able to connect from a client on the same LAN as the Terminal Server. In case you cannot, you will need to telnet to port 3389. Check if the TS is listening on port 3389, and also if you cannot connect from any client, or just some of them.




Login/Register to Answer

Related Questions