PostgreSQl on Jasper report problem

Asked By 750 points N/A Posted on -

Hi folks,

I have some PostgreSQL driver issue while working, this is the error I encountered.


Msg: org.postgresql.Driver

This class may not have been found: org.postgresql.Driver

I am using Jasper report. I am on my hands in creating reports from PostgreSQL database using Jasper report, database is not installed on my machine. I already installed JavaServer Pro 3.0 and iReport 3.0.0. I started javaserver and it seems to be doing great since its up and Running and I start iReport, it opens cmd window and open iReport.

But I can't see any ODBC connection in database creation window. I use my own database name instead of the default DBname, when testing  the connection the error stated above shows. I was able to obtain a copy of the file postgresql-8.2-504.jdbc3 and put it  in Jasperscriptslib. I also tried other drivers, but same error again. I am now asking somebody to throw light on this matter.

Thanks in advance.

Answered By 0 points N/A #122680

PostgreSQl on Jasper report problem


Hello Thomas,

I'm a big fan of databases, and based on my daily activities I have need to use them quite often, that being said I also have the problem of having to reconfigure the databases depending on what I'm doing. With that being said when working with JDBC ODBC drivers, it is very important that you have an explicit link to the database, not only that you have to ensure that the database is setup and that you have access to it before you try anything.

Looking into what you've done so far there seems to be one thing that you probably didn't try. Did you update your java??? I know it seems silly but it’s true, not all java is java lol, if you're running anything lower than 1.6 then that would be the true source of your problem.

One more thing as well, try doing a full reinstall of the drivers and postgresql, use revo uninstaller to ensure that all remnants of the program is removed that will ensure that you don’t have any lagging configuration issues that might have came up during the time you were trying to fix the problem

In any case good luck 😀

Login/Register to Answer

Related Questions